Closed Bug 415604 Opened 13 years ago Closed 13 years ago

Determine list of locales for Firefox 3 Beta 3

Categories

(Firefox Build System :: General, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla3 beta3

People

(Reporter: Pike, Assigned: mic)

References

Details

Attachments

(2 files, 1 obsolete file)

Search review pending, we gotta determine the list of locales to ship for Beta 3.

We had some post-freeze check-ins that I'd like to take, so

2008-02-04 08:00 PST

sounds like a good date to tag. Note, this is 8am PST, not UTC, which is the post-freeze bustage landing window.
Flags: blocking-firefox3?
Version: unspecified → Trunk
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P1
Depends on: 415662
We had to take a bustage fix for zh-TW.

We need to push the timestamp forward to 

2008-02-04 15:20 PST.
here is the list:

ar
be
ca
cs
de
en-US
eu
fi
fr
fy-NL
ga-IE
gu-IN
he
hu
it
ka
ko
lt
nb-NO
nl
pa-IN
pl
pt-BR
pt-PT
ro
ru
sk
sv-SE
tr
uk
zh-CN
zh-TW
As Mic doesn't have CVS access, setting checkin-needed keyword.
Keywords: checkin-needed
Attached patch patch - v1Splinter Review
Attachment #301396 - Flags: review?(l10n)
Attachment #301396 - Flags: approval1.9b3?
Attachment #301396 - Flags: review?(l10n) → review+
Attachment #301396 - Flags: approval1.9b3? → approval1.9b3+
Checking in browser/locales/shipped-locales;
/cvsroot/mozilla/browser/locales/shipped-locales,v  <--  shipped-locales
new revision: 1.4; previous revision: 1.3
done
Status: NEW → RESOLVED
Closed: 13 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
no ja (Japanese) version ?
Sadly, no, no Japanese for B3.
Attached patch include ja/ja-JP-mac (obsolete) — Splinter Review
I could not be in time for b3 l10n freeze. I'm really sorry.
It's late but I finished ja/ja-JP-mac l10n work now.
Please include Japanese builds for Fxb3.
Attachment #301611 - Flags: review?(l10n)
Thank you dynamis.  Just a clarification: dynamis was late because Mozilla Japan needed time to confirm the changes with our partners in Japan and this took longer than expected.  So please do not blame dynamis for the ja locale lateness.
> Thank you dynamis.  Just a clarification: dynamis was late because Mozilla
> Japan needed time to confirm the changes with our partners in Japan and this
> took longer than expected.  So please do not blame dynamis for the ja locale
> lateness.
Are you a liar? And, are you serious?
Mr. dynamis says that he was misunderstanding the time limit. 
Do you make him a liar?
(In reply to comment #10)

> Are you a liar? And, are you serious?

I am not a liar.  I am very serious.

> Mr. dynamis says that he was misunderstanding the time limit. 
> Do you make him a liar?

I did not call dynamis a liar.  In fact, if you read my comment, I was thanking him.

Calling someone a liar is a serious accusation.  Please understand the severity of your words before you use them in such a manner.
 
Can you read Japanese language?
http://forums.firehacks.org/l10n/viewtopic.php?p=7664#7664

Japanese Mozilla community People are reading this comment of Mr. dynamis. 
If you try to do a useless following for Mr. dynamis, it is harmful. 
You and he lose one's trust. 

Make to either, and your and my comment is spam. 
Attachment #301776 - Flags: review?(l10n) → review+
Comment on attachment 301611 [details] [diff] [review]
include ja/ja-JP-mac

... obsoleted by attachment 301776 [details] [diff] [review]
Attachment #301611 - Attachment is obsolete: true
Attachment #301611 - Flags: review?(l10n)
Comment on attachment 301776 [details] [diff] [review]
add es-ES, ja, ja-JP-mac for 3.0b3 RC3

Landed on trunk and relbranch:

Checking in shipped-locales;
/cvsroot/mozilla/browser/locales/shipped-locales,v  <--  shipped-locales
new revision: 1.5; previous revision: 1.4
done

Checking in shipped-locales;
/cvsroot/mozilla/browser/locales/shipped-locales,v  <--  shipped-locales
new revision: 1.4.2.1; previous revision: 1.4
done
Sorry for our spam on here, noreply needed.

AKIHIRO Misaki (a.k.a Kuden),
both I and Gen are not liar, just communication between Gen and me was not enough. I don't hide my fault. I was too busy with my thesis and could not confirm the schedule enough and could not be in time.
Here is bugzilla and I wrote very simple word (how I delayed is not matter) but I already wrote more details in mail to release-drivers and others.

About Gen's words, actually Mozilla Japan Marketting team is now confirming the changes with our partners in Japan. Selection of searchplugin for Fx3 was just decided yesterday (I'm not sure about exact day) and confirming with partners now.
# new searchplugins will be included in Fx3b4 and later

Gen was not know enough about my l10n work status and he just thought that the delay of the marketting decision made l10n delay too.

What ever the cause of delay is, it's my fault since I'm responsible to make Japanese Firefox released. Sorry and thanks to everyone relating this.

Thanks keeping your eyes on l10n, Kuden.
pa-IN, ja, ja-JP, and es-ES now appear in the beta 3 rc3 folder.    See ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.0b3-candidates/rc3/. 

Fix verified.
Status: RESOLVED → VERIFIED
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 3 beta3 → mozilla3 beta3
You need to log in before you can comment on or make changes to this bug.