Closed Bug 415759 Opened 12 years ago Closed 12 years ago

Javascript errors starting Sunbird with a clean profile

Categories

(Calendar :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jminta, Assigned: mvl)

Details

(Keywords: regression)

Attachments

(1 file)

When starting Sunbird the first time, 2 javascript errors appear:

Error: minimonth has no properties
Source File: chrome://calendar/content/calendar-minimonth-busy.js
Line: 196
Error: unifinderTree has no properties
Source File: chrome://calendar/content/calendar-unifinder.js
Line: 203
Flags: blocking-calendar0.8?
Joey, what's the rationale for this blocking 0.8? Does this cause any bugs? If yes, which bugs?
I haven't noticed any specific user-facing bugs as a result, but I'm not sure.  Suffice it to say that the thrown errors mean that the functions containing them don't run to completion.  That means that someone is trying to add a listener to the minimonth and failing http://mxr.mozilla.org/seamonkey/source/calendar/base/content/calendar-minimonth-busy.js#196 and that someone who wants to add listeners to the views is not http://lxr.mozilla.org/mozilla/source/calendar/base/content/calendar-unifinder.js#205

That leaves two options: either these listeners aren't getting added at all, or the errors are masking the fact that the current code is double-calling these functions, which would be a performance hit.

The uncertainty about this is simply my way of saying this should block because any javascript error is a sign the program is not doing what it should be doing.  In my opinion, it should block until someone at least proves the errors harmless, or until they're fixed.

Would you really be willing to ship with known code-flow errors in the program? It strikes me as unprofessional at best.
I agree this blocks.
I don't see this errors using Sunbird 0.8pre (2008020507) or Sunbird 0.6a1 (2008020418) on Windows XP.

The bug is filed for Trunk - does this also happens using a mozilla1.8 branch build? Can you narrow down the regression range?
(In reply to comment #4)
Sorry, I didn't bother with the defaults for version, etc.  This happens with the latest nightly build on Mac.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12pre) Gecko/20080204 Calendar/0.8pre

The minimonth error has existed since prior to 0.7, I don't have a range on the unifinderTree error.
Version: Trunk → Mozilla 1.8 Branch
Needs investigation. And no, we don't want to ship with js errors, at least not with code errors.
Flags: blocking-calendar0.8? → blocking-calendar0.8+
For now, my guess is that at least the minimonth error is related to the mac hidden window. That window also includes the js script. But there is of course no minimonth in that window, so the code fails.
I indeed to not see any errors on my linux build. (but that's severly hacked, so i don't want to draw too much conclusions from it)
I don't have a mac right now to test if the function is indeed called twice.
Assignee: nobody → Berend.Cornelius
Attached patch patchSplinter Review
I indeed see the onload function called twice. This confirms that one is the hidden window. In that window, there are no minimonths etc to attach any listeners to. So the checks I added in the patch are safe.
Attachment #302120 - Flags: review?(philipp)
Assignee: Berend.Cornelius → mvl
Comment on attachment 302120 [details] [diff] [review]
patch

Looks good, thanks for taking care! r=philipp
Attachment #302120 - Flags: review?(philipp) → review+
patch checked in
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Version: Mozilla 1.8 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.