firefox doesnt close filedescriptors after fork() but before exec()

RESOLVED DUPLICATE of bug 147659

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 147659
10 years ago
9 years ago

People

(Reporter: martin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2008020404 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2008020404 Minefield/3.0b3pre

When firefox launches external apps on linux the child process will have lots of redundant file descriptors open, even the sound device etc.

I have verified this bug using minefield from feb1 running on ubuntu gutsy.

Reproducible: Always

Steps to Reproduce:
1. open a youtube video and let it play
2. run "fuser /dev/snd/*" and verify that firefox's pid is using the sound device
3. open a PDF file (so that it starts in evince or kpdf or any external app really)
4. re-run "fuser /dev/snd/*" and notice that the PDF viewer is now using the sound device as well
(Reporter)

Comment 1

10 years ago
See also discussion in this kpdf report, apparently a lot of people are running into this bug:

http://bugs.kde.org/show_bug.cgi?id=148470
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 147659

Updated

10 years ago
Duplicate of this bug: 415808
Flags: blocking-firefox3?
You need to log in before you can comment on or make changes to this bug.