AIX Compilation error for trunk build source jdcolor.c :Operation between types "unsigned char" and "unsigned char*" is not allowed

RESOLVED DUPLICATE of bug 44781

Status

()

Firefox
Build Config
--
major
RESOLVED DUPLICATE of bug 44781
10 years ago
8 years ago

People

(Reporter: Shailen, Unassigned)

Tracking

Trunk
Other
AIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

While compiling trunk build source mozilla/jpeg/jdcolor.c on
AIX, getting below compilation error -

mozilla/jpeg/jdcolor.c", line 299.8: 1506-234 (E) Expecting a new-line character on #endif directive.
mozilla/jpeg/jdcolor.c", line 464.17: 1506-068 (S) Operation between types "unsigned char" and "unsigned char*" is not allowed.
mozilla/jpeg/jdcolor.c", line 465.17: 1506-068 (S) Operation between types "unsigned char" and "unsigned char*" is not allowed.
mozilla/jpeg/jdcolor.c", line 468.17: 1506-068 (S) Operation between types "unsigned char" and "unsigned char*" is not allowed.
gmake[1]: *** [jdcolor.o] Error 1




Reproducible: Always

Steps to Reproduce:
1.Build Mozilla Firefox Trunk build on AIX with Gnome 2.12 RPMS of 64 bit
version.
2.
3.
Actual Results:  
Build fails with the above errors.

Expected Results:  
No build failure
(Reporter)

Updated

10 years ago
OS: Other → AIX
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
Created attachment 301627 [details] [diff] [review]
Patch V1

Modified the code to have operation between unsigned chars
Attachment #301627 - Flags: review?(benjamin)

Comment 2

10 years ago
Comment on attachment 301627 [details] [diff] [review]
Patch V1

I think this is libjpeg... asking stuart, the module owner, for review.
Attachment #301627 - Flags: review?(benjamin) → review?(pavlov)

Updated

10 years ago
Attachment #301627 - Flags: review?(pavlov) → review?(marti.maria)

Comment 3

10 years ago
Marti:  Can you take a look at this patch?

Comment 4

10 years ago
Sure, but this is not related with littlecms. Maybe the author/mantainer of libjpeg would be more proper.

Comment 5

10 years ago
Comment on attachment 301627 [details] [diff] [review]
Patch V1

argh, whoops.  not sure why i thought this was in littlecms....  I'll take a look at it.
Attachment #301627 - Flags: review?(marti.maria) → review?(pavlov)
(Reporter)

Comment 6

10 years ago
I am able to compile the trunk build without the above errors. I believe the error is fixed with bug 44781 fix.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 44781

Updated

8 years ago
Attachment #301627 - Attachment is obsolete: true
Attachment #301627 - Flags: review?(pavlov)
You need to log in before you can comment on or make changes to this bug.