Sametime meetingroom applet no longer loads

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
11 years ago
3 years ago

People

(Reporter: wgianopoulos, Unassigned)

Tracking

({regression})

Trunk
regression
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Bug 406807 removed the function InstallTrigger.getVersion.  Unfortunately the dumb javascript that runs on the sametime server to figure out how to install it's plugin makes use of this function to determine which codepath to take.

Error console shows:

InstallTrigger.getVersion is not a function
http://<hostname>/sametime/stdetect.js Line:1069

We are running an older version of the sametime server.  This does not appear to be an issue with the latest version, however getting large enterprises to update software to accommodate a "not our standard browser" it kind of a fruitless effort

I also wonder if other client server type applications might require this function in order to properly install the client side code.
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
Looking further into the script, it also uses InstallTrigger.compareVersion.  I am trying to contact our Sametime support group to find out if this is a custom written script by them or if this is the original IBM/Lotus version of this script.
(Reporter)

Comment 2

11 years ago
According to our Sametime support team, this JavaScript is unmodified from the way it was delivered as part of the Sametime Meetingroom code from IBM/Lotus.

As I said, the latest version of the Sametime server software does NOT have this issue.
(Reporter)

Comment 3

11 years ago
I also found out from out Sametime support group that we will be upgrading to a version that does not have this issue next week.

So, I guess if this does not turn out to be an issue for anyone else, it is then no longer an issue.

Comment 4

11 years ago
This is a problem for us as well.  Our IT department will not upgrade any time soon.

Updated

11 years ago
Flags: blocking1.9? → blocking1.9-
Since the whole rest of the xpinstall script processing code was removed as well would the plugin install even if .getVersion() is still present? In FF3 only ExtensionManager (install.rdf) type installs work and plugins tended to use the old install.js style.
(Reporter)

Comment 6

11 years ago
I have no (In reply to comment #5)
> Since the whole rest of the xpinstall script processing code was removed as
> well would the plugin install even if .getVersion() is still present? In FF3
> only ExtensionManager (install.rdf) type installs work and plugins tended to
> use the old install.js style.
> 
I have no idea.  All I know is that before the checkin for bug 406807 this worked just fine and since then it does not.
(Reporter)

Comment 7

7 years ago
This problem went away quite some time ago.

->> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.