Last Comment Bug 415919 - No AT-SPI focus event when returning focus to Firefox
: No AT-SPI focus event when returning focus to Firefox
Status: RESOLVED FIXED
: access
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Aaron Leventhal
:
: alexander :surkov
Mentors:
Depends on:
Blocks: fox3access
  Show dependency treegraph
 
Reported: 2008-02-06 07:09 PST by Scott Haeger
Modified: 2008-02-11 09:26 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Scott Haeger 2008-02-06 07:09:45 PST
There is no state-changed:focus or focus event being fired when returning focus to Firefox.  The problem was introduced into the 1/28 nightly build (1/27=good, 1/28=bad).
Comment 1 Aaron Leventhal 2008-02-06 08:11:41 PST
That's the date I suspected we broke it.
It must be https://bugzilla.mozilla.org/show_bug.cgi?id=413778 which didn't properly fix that bug anyway.
Comment 2 Aaron Leventhal 2008-02-06 12:35:33 PST
Fixed by backing out fix for bug 413778.
Comment 3 Marco Zehe (:MarcoZ) 2008-02-11 09:26:48 PST
Note for RelNote: People interested in testing Linux a11y should continue to test nightly builds instead of Beta 3. The process of getting the latest nightly build set up with the Orca screen reader can be found here: http://live.gnome.org/Orca/Firefox#preview.

Note You need to log in before you can comment on or make changes to this bug.