Closed Bug 416048 Opened 12 years ago Closed 11 years ago

All popup windows do not close when using File | Exit at popuptest.com

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

()

Details

Seen using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3.

STR:
1. Visit the URL above and allow the popups.
2. Quit the browser using File | Quit and either "Save and Quit" or Quit (does not matter, you get the same result)

Actual: Two popup windows do not close.
Expected: Since I quit the browser all windows would close.

Tomcat sees this on a debug build as well.
I tried a different site that had popups, orbitz.com. The one popup that launched from the site *did* close when I quit the browser. Maybe something specific to the popuptest site?
I've seen on weather.com (which btw the popups there have always made it past Firefox) close on exit, but occasionaly open in a tab open restarting Firefox.
So, yeah, I definitely see this with Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3.
I see this also in a June 2004 build on Windows XP so it is not a (recent) regression.
Yeah, I can reproduce on Firefox 2.x as well. We seem to be honouring popups that appear on close when we exit. That's silly of us.

Sadly, not blocking.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Ah, not really a huge deal then since it requires you to whitelist the site in the popup blocker to work?

Would be great if someone could come up with a minimal testcase.
This seems to be fixed in Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b2pre) Gecko/20081118 Minefield/3.1b2pre ID:20081118020315. Firefox exits - all windows are closed.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Since we don't know exactly what changed it, WFM.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.