Download Manager list takes ages to populate with large download history

RESOLVED DUPLICATE of bug 413209

Status

()

RESOLVED DUPLICATE of bug 413209
11 years ago
11 years ago

People

(Reporter: stevee, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020702 Minefield/3.0b4pre ID:2008020702

I have a very large download history, over 650 items, and it takes a silly length of time for the download manager window to populate with the complete history. This somewhat reduces the usefulness of being able to remember such a long download history.

Is there someway we can change how the list is lazily populated? At the moment, it appears to add 5 items every second or something. (So it takes 130 seconds or over 2 minutes of my time for my list to appear in its entirety). Could we dynamically change how many items are added at a time based on the size of the download history and the length of time we think it's reasonable for a user to wait to see their whole history?
(Reporter)

Updated

11 years ago
Summary: Download Manager list takes ages to populate → Download Manager list takes ages to populate with large download history
This is a duplicate of bug 413209, which itself is pretty nearly a duplicate of 410538.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 413209
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.