session restore busted after 393716 checkin

VERIFIED FIXED in Firefox 3 beta4

Status

()

P1
blocker
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: aja+bugzilla, Assigned: zeniko)

Tracking

({dataloss, regression})

Trunk
Firefox 3 beta4
dataloss, regression
Points:
---
Bug Flags:
blocking-firefox3 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Things messed up for me first build after patch for bug 393716 got checked in.

Basically, tabs that were okay when you shutdown/restart never load upon startup.
Even with a brand new sessionstore.js, I'm only getting the first and last restored tabs to load....the rest just sit there with throbbers and "Loading..."

Following two messages are showing up in console2 error log:

Error: aEntry is undefined
Source file: file:///D:/Program%20Files/Minefield/firefox/components/nsSessionStore.js
Line: 1609

Error: aEntry is undefined
Source file: file:///D:/Program%20Files/Minefield/firefox/components/nsSessionStore.js
Line: 1193
(Reporter)

Comment 1

11 years ago
Lines 1608 & 1609:
    var ioService = Cc["@mozilla.org/network/io-service;1"].
                    getService(Ci.nsIIOService);

Line 1193:
    function extractHosts(aEntry) {
Blocks: 393716

Updated

11 years ago
Flags: blocking-firefox3?
Keywords: regression
1. New profile, start firefox
2. Turn session restore on
3. Surf to some tabs, like www.neowin.net www.shacknews.com www.doom9.org
4. Close Firefox, and start it up again

Works: 20080207_0035_firefox-3.0b4pre.en-US.win32
Broken: 20080207_0142_firefox-3.0b4pre.en-US.win32

Checkins to module PhoenixTinderbox between 2008-02-07 00:35 and 2008-02-07 01:41 :
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1202373300&maxdate=1202377319
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> 1. New profile, start firefox
> 2. Turn session restore on
> 3. Surf to some tabs, like www.neowin.net www.shacknews.com www.doom9.org
> 4. Close Firefox, and start it up again
> 
> Works: 20080207_0035_firefox-3.0b4pre.en-US.win32
> Broken: 20080207_0142_firefox-3.0b4pre.en-US.win32
> 
> Checkins to module PhoenixTinderbox between 2008-02-07 00:35 and 2008-02-07
> 01:41 :
> http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1202373300&maxdate=1202377319
> 

I concur with the above steps to repro, works/broken builds, and regression range. (he's quicker than I am sometimes :)
(Assignee)

Comment 4

11 years ago
Note to self: This only happens on pages containing (i)frames. Investigating...
Status: NEW → ASSIGNED
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> Note to self: This only happens on pages containing (i)frames. Investigating...
> 
Could well be....tinderbox waterfall page is one I normally have open.
(Assignee)

Comment 6

11 years ago
Created attachment 301898 [details] [diff] [review]
fix embarassing typo

Turns out that I've misplaced one parenthesis. Sorry for that!
Assignee: nobody → zeniko
Attachment #301898 - Flags: review?(dietrich)
Attachment #301898 - Flags: approval1.9?
Comment on attachment 301898 [details] [diff] [review]
fix embarassing typo

ouch. apologies for missing that in the initial review!
Attachment #301898 - Flags: review?(dietrich) → review+
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → Firefox 3 beta4

Updated

11 years ago
Severity: normal → blocker
I just landed this without approval since it's a one character bustage/typo fix.

Checking in browser/components/sessionstore/src/nsSessionStore.js;
/cvsroot/mozilla/browser/components/sessionstore/src/nsSessionStore.js,v  <--  nsSessionStore.js
new revision: 1.96; previous revision: 1.95
done

I'll go respin nightlies now.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite?
Resolution: --- → FIXED

Updated

11 years ago
Keywords: dataloss
Flags: blocking-firefox3? → blocking-firefox3+
Comment on attachment 301898 [details] [diff] [review]
fix embarassing typo

This is now a blocker and doesn't need it, but I loves me my session restore, so a=beltzner for good measure!
Attachment #301898 - Flags: approval1.9? → approval1.9+

Comment 10

11 years ago
I am getting this problem also.  Including with the 8am build.  (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008020708 Minefield/3.0b4pre)

STR: 
1) close minefield
2) restart minefield
3) see all tabs saying "Loading..." with throbber spinning.

Error Console:

Error: Warning: unrecognized command line flag -foreground
Source File: file:///Users/timr/Desktop/Firefox%20installations/FF3Nightly-20071211/Minefield.app/Contents/MacOS/components/nsBrowserContentHandler.js
Line: 660

Error: aEntry is undefined
Source File: file:///Users/timr/Desktop/Firefox%20installations/FF3Nightly-20071211/Minefield.app/Contents/MacOS/components/nsSessionStore.js
Line: 1609

Error: aEntry is undefined
Source File: file:///Users/timr/Desktop/Firefox%20installations/FF3Nightly-20071211/Minefield.app/Contents/MacOS/components/nsSessionStore.js
Line: 1193

New tabs open properly.
(Assignee)

Comment 11

11 years ago
(In reply to comment #10)
> I am getting this problem also.  Including with the 8am build.

Once you've used a broken build, you have to delete the corrupted sessionstore.js from your profile to get things working again.

Comment 12

11 years ago
stevee, can you still repro this?  if not, we can mark this bug verified.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008022711 Minefield/3.0b4pre ID:2008022711
-->VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.