Underbraces and Overbraces don't stretch properly

RESOLVED FIXED in mozilla1.9.3a5

Status

()

RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: distler, Assigned: fredw)

Tracking

Trunk
mozilla1.9.3a5
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008020201 SeaMonkey/2.0a1pre
Build Identifier: 

They either don't stretch enough, or they stretch too much, depending on the length of the base.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

11 years ago
Created attachment 301919 [details]
testcase
(Reporter)

Comment 2

11 years ago
Created attachment 301920 [details]
screenshot
We need some more sizes of braces.
The suggestions in bug 407101 and bug 414277 would resolve this.
Status: UNCONFIRMED → NEW
Depends on: 407101, 414277
Ever confirmed: true
(Reporter)

Comment 4

10 years ago
Created attachment 335152 [details]
screenshot from Camino trunk

Interestingly, the rendering is different on the latest Camino trunk. Only the smallest size under- and over-braces are used.

Updated

9 years ago
Duplicate of this bug: 502200

Comment 6

9 years ago
Created attachment 388271 [details]
Shows this bug and problem with braces in tables

Created a webpage that shows this bug and how it screws up putting braces inside of table cells (Same as image provided).  It looks like the brace's size is not given to the table so that the table can position the braces correctly, there should be a 3px padding.
https://eyeasme.com/Joe/MathML/OverBrace_UnderBrace_Bug.html

Comment 7

8 years ago
Created attachment 445115 [details]
trunk build image of https://eyeasme.com/Joe/MathML/OverBrace_UnderBrace_Bug.html

Bug seem to be fixed as the attachment shows, BUT there seems to be an image
degradation as the next attachment/comment shows.

Comment 8

8 years ago
Created attachment 445117 [details]
notice image degradation of underbraces

Images from
https://eyeasme.com/Joe/MathML/MathML_browser_test
using
Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100513 Minefield/3.7a5pre

First image is of TeX, then next is Firefox 3.5 and the last is trunk build

Notice that the underbraces are less defined in the latest trunk release.
(In reply to comment #8)
> Notice that the underbraces are less defined in the latest trunk release.

If you are referring to smaller hooks and thinner lines, I think that's just from rendering at small font sizes and from STIX fonts choosing to make the line thickness similar to the thickness of stems in other characters.

Fixed after changes in bug 407101.
Assignee: nobody → fred.wang
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.