Closed Bug 416190 Opened 12 years ago Closed 11 years ago

Privacy of a meeting should not impact transparency

Categories

(Calendar :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nomisvai, Assigned: nomisvai)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20080120 Calendar/0.8pre

When creating a meeting, if Privacy->Private is chosen, the meeting will be made transparent, if the other 2 privacy are chosen, the meeting is made opaque. I don't think this is appropriate.  I understand that this was probably implemented with the idea that someone creating a "private" meeting would not want that meeting to show up in a freebusy lookup, but this only gives a false sense of privacy since other access right systems would come into play if another user was to open  the user's agenda itself instead of looking at a freebusy.

I think that by default, day events should be transparent and normal events opaque, with all privacy settings, while both properties remaining settable separately. 





Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Sounds reasonable. Time transparency (property TRANSP) is already controlled via the menu "Show Time as -> Busy/Free". Currently setting the privacy to private or public will silently overwrite any previous user decision made for the time transparency -> kind of dataloss. http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/calendar/prototypes/wcap/sun-calendar-event-dialog.js&rev=1.1.2.67&mark=1110-1115#1106
Assignee: nobody → simon.at.orcl
OS: Windows XP → All
Hardware: x86 → All
Comment on attachment 355718 [details] [diff] [review]
Patch that makes privacy changes not affect transparency

patch looks good, thanks!

r=dbo
Attachment #355718 - Flags: review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/88259c746914>

-> FIXED
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.