Closed Bug 416251 Opened 12 years ago Closed 12 years ago

set up suite of machines for jss testing.

Categories

(Release Engineering :: General, defect, P2)

All
Windows XP
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: anodelman, Assigned: anodelman)

References

Details

Attachments

(2 files, 1 obsolete file)

We don't want to add another half an hour to the currently up talos machines' cycle time, so we are going to set up machines to only run jss tests.  

Proposed machines:

- 3 winxp trunk
- 3 mac10.4.8 trunk
name them qm-pmac-jss01/02/03 and qm-pxp-jss01/02/03
Assignee: server-ops → phong.tran
Just need 3x windows machine - qm-pxp-jss01/02/03.  Phong can you get these up?
I will get the 3 XP machines imaged.
qm-pxp-jss01	Windows XP	ym3992zxyl1	1310	ASX101-06A-04	10.2.73.207	103.06.602
qm-pxp-jss02	Windows XP	ym7392z7yl1	1311	ASX101-06A-06	10.2.73.209	103.06.603
qm-pxp-jss03	Windows XP	ym7393c6yl1	1312	ASX101-06A-08	10.2.73.208	103.06.604
Status: NEW → ASSIGNED
Assignee: phong.tran → justin
Status: ASSIGNED → NEW
I think that this is waiting on LDAP magic?

I get the following error when attempting to VNC to the machines:

channel 7: open failed: administratively prohibited: open failed
looks like all come up but jss02 - mrz, please check this and get a mac.
Flags: colo-trip+
I can get into qm-pxp-jss01/03 via RDP using the mozqa account/pass...no idea if vnc is setup or supposed to be.
Assignee: justin → anodelman
Status: NEW → ASSIGNED
Attachment #304554 - Flags: review?(ccooper)
jss02 is up, done from a server-ops side.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Re-opening as core/testing bug to finish off the buildbot work.
Status: RESOLVED → REOPENED
Component: Server Operations → Testing
Flags: colo-trip+
Product: mozilla.org → Core
Resolution: FIXED → ---
Version: other → unspecified
Status: REOPENED → ASSIGNED
Comment on attachment 304554 [details] [diff] [review]
add jss machines to stage

Buildbot changes look fine, but I don't know enough to comment knowledgeably about the jss sample config. I suppose it's only a sample after all.
Attachment #304554 - Flags: review?(ccooper) → review+
Checking in master.cfg;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/master.cfg,v  <--  master.cfg
new revision: 1.37; previous revision: 1.36
done
RCS file: /cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/configs/jss.sample.config,v
done
Checking in configs/jss.sample.config;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/configs/jss.sample.config,v  <--  jss.sample.config
initial revision: 1.1
done
These are up and reporting to stage.  Currently qm-pxp-jss03 is never getting to test due to bug 419071.
Once we get full exercise of the machines these will be pushed to production - with the new talos staging set up that should be soon.
Assignee: anodelman → nobody
Status: ASSIGNED → NEW
Component: Testing → Release Engineering
OS: Mac OS X → Windows XP
Priority: -- → P2
Product: Core → mozilla.org
QA Contact: justin → release
Hardware: PC → All
Version: unspecified → other
Attached patch push jss machines to production (obsolete) — Splinter Review
All of the jss only machines have reported and their numbers are consistent.  I believe that they are ready to be moved to production.
Assignee: nobody → anodelman
Status: NEW → ASSIGNED
Attachment #310109 - Flags: review?(rcampbell)
Comment on attachment 310109 [details] [diff] [review]
push jss machines to production

looks good to go
Attachment #310109 - Flags: review?(rcampbell) → review+
Comment on attachment 310109 [details] [diff] [review]
push jss machines to production

sorry, spoke too soon. This should be based on the latest checkout from production buildbot-configs. Those sections no longer exist since staging has been deployed.
Attachment #310109 - Flags: review+ → review-
Attachment #310109 - Attachment is obsolete: true
Attachment #310294 - Flags: review?(rcampbell)
Attachment #310294 - Flags: review?(rcampbell) → review+
push to production:

Checking in master.cfg;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/master.cfg,v  <--  master.cfg
new revision: 1.50; previous revision: 1.49
done
RCS file: /cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/configs/jss.production.sample.config,v
done
Checking in configs/jss.production.sample.config;
/cvsroot/mozilla/tools/buildbot-configs/testing/talos/perfmaster/configs/jss.production.sample.config,v  <--  jss.production.sample.config
initial revision: 1.1
done
Up and reporting to Firefox tinderbox waterfall.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Component: Release Engineering: Talos → Release Engineering
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.