Firefox says "File not found" on server's "500 Internal server error" response

VERIFIED INVALID

Status

()

Core
Networking: HTTP
--
minor
VERIFIED INVALID
10 years ago
10 years ago

People

(Reporter: Radek 'sysKin' Czyz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020708 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020708 Minefield/3.0b4pre

I hit this today when visiting http://cvs.xvid.org/cvs/viewvc.cgi . The server returns:
  HTTP/1.x 500 Internal Server Error
  Date: Fri, 08 Feb 2008 03:26:20 GMT
  Server: Apache/2.2.0 (Linux/SUSE)
  Content-Length: 0
  Content-Type: application/x-cgi
  Connection: close

Byt firefox shows "File not found" error page, rather than "Internal server error" page.


Reproducible: Always

Steps to Reproduce:
1. visit a wbsite that gives "500" response with no other content

Actual Results:  
"File not found"

Expected Results:  
"Internal server error"

FF2 is doing something ever weirder (trying to save the zero-sized error page?) so I'm not sure what's going on.
Status: UNCONFIRMED → NEW
Component: General → Networking: HTTP
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → networking.http
That URL no longer returns a 500, I can't reproduce :( I could when this was filed, but didn't get a chance to debug before now. Tried creating my own testcase, but didn't have much luck.
Gavin It send the 500 with a content type other then text/plain or Text/html as far as I remember
(Reporter)

Comment 3

10 years ago
I quoted all headers in comment 0, but the two headers that are needed are: 500 response and a content type. Content-Length is not needed.

I made up a new testcase using php.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 4

10 years ago
Intentional change from bug 312727.
Blocks: 312727
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
verified based on my comment #2 that the server sent the http 500 with a content type other than text/plain or text/html which would create a helper app window.


Status: RESOLVED → VERIFIED

Comment 6

10 years ago
The error message "File Not Found" isn't quite accurate in this case, fwiw.
(Reporter)

Comment 7

10 years ago
(In reply to comment #4)
> Intentional change from bug 312727.

That bug was about not popping up a download dialogue, not about morphing all server errors into into 404 :)

Having said that, this is too rare and too trivial to bother anyone with reopening. Unless you feel otherwise.

Comment 8

10 years ago
I filed bug 426961 on using a less misleading error message.
You need to log in before you can comment on or make changes to this bug.