Numeric accesskeys on HTML element don't work

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Away for a while, Unassigned)

Tracking

({access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020913 Minefield/3.0b4pre

Numeric access keys on HTML elements don't work.  For example, in <http://www.cs.tut.fi/~jkorpela/forms/accesskey.html>, Alt+Shift+1 should take you to <http://www.cs.tut.fi/~jkorpela/index.html>, but it does nothing.  The problem seems with this code:

<http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/content/events/src/nsEventStateManager.cpp&rev=1.728&mark=1411-1412#1405>

The above code attempts to match the accesskey attribute against aKey, which is "!" when Alt+Shift+1 is pressed, and this comparison fails.

This seems to be a regression from bug 143065.  Therefore, I'm requesting blocking1.9.
Flags: blocking1.9?

Comment 1

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020804

WORKSFORME. Dupe of bug 359638?
Blocks: 143065
No longer depends on: 143065
(Reporter)

Comment 2

10 years ago
OK, on further investigation, this was caused by a patch in bug 414130 (attachment 300143 [details] [diff] [review]) which I was testing.  I'll add the appropriate notes to that bug.  We can close this one as WORKSFORME.  Sorry for the bug spam.
Blocks: 414130
No longer blocks: 143065
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking1.9?
Keywords: regression
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.