If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Option to show alt texts even if they won't fit in image size

VERIFIED DUPLICATE of bug 34981

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 34981
18 years ago
17 years ago

People

(Reporter: Antti Näyhä, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
In current Mozilla builds, if an image isn't displayed and the alt text doesn't 
fit in the specified (by the width & height attributes) image size, the alt text 
gets truncated.  This is a serious accessibility problem, since we're not 
displaying the alt text as a tooltip, either (which is correct).

The most obvious solution to this problem is an "Always expand alt texts for 
images" option in the preferences (see IE4/5 for Windows, Options/Advanced).
(Reporter)

Comment 1

18 years ago
Ian is probably the QA Contact for this one, since we're dealing with alt texts.
Also nominating nsbeta3 and adding '4xp' keyword since competitors have this 
feature.
Keywords: 4xp, nsbeta3
QA Contact: ckritzer → py8ieh=bugzilla

Comment 2

18 years ago
Created attachment 9722 [details]
testcase

Comment 3

18 years ago
You will be glad to learn that it got fixed in the past couple of days. We now 
have the following behaviors:

Mac IE5 / Win IE5: The alt text is truncated if it can't be displayed within the 
boundaries. The broken image icon is always displayed.

Mac Nav4x / Win Nav4x: The alt text and the broken image icon don't show at all 
if the width/height are too small to display them entirely. When there is no 
specified width/height, they are displayed correctly.

Moz Mac/Win 2000-06-06: It doesn't make any difference to specify a width/height. 
When the image is broken, it displays  the entire alt text (no truncation) or the 
image name (ie. "plouc" for "plouc.jpg"). There is no broken-image icon.

Comment 4

18 years ago
In my opinion however, the bug as originally described is invalid. We should 
behave like IE5. I don't understand why you mention accessibility problems: alt 
texts are for the blind and non-visual browsers, well, ignore the width/height 
and read the entire alt text without truncating it. Similarly if a speach module 
is implemented on top of a CSS-aware visual browser like MacIE5 or Moz, it is 
possible to put an important rule in UA.css that sets the width/height/margins of 
image elements to 'auto'.

Overall, I think that we should:
- always display a small (broken?) image icon
- truncate the alt text (or the image name) if the specified width/height are too 
small
- display the entire alt text (or image name) if there is no specified width/
height

Changed title from "alt texts must be shown even if they won't fit in image size" 
to "issues with broken images". Reassigned to buster.

CCd dbaron. David and Ian: your comments are welcome. I personally have no 
experience with non-visual browsers, nor speach modules on top of visual 
browsers.
Assignee: pierre → buster
Component: Style System → Layout
Summary: alt texts must be shown even if they won't fit in image size → issues with broken images
(Reporter)

Comment 5

18 years ago
I wasn't talking specifically about _broken_ images, but generally about images 
which aren't loaded for whatever reason - alt texts are also meant for graphical 
browsers with image loading turned off.

An easy-to-reproduce example:
 1) Go to Preferences > Advanced > Cookies and Images
 2) Select Do not load any images
 3) Go to www.w3.org
 4) Read the name of the site: "The World Wide".  Other informative alt texts on
    the page include "M", "IN", "K" and "CI". :-P

So we need an option to enlarge all image frames to fit all of the alt text.  
It's probably not wise to do this by default, since the layout on some sites 
rely on exact specified image sizes - so I propose the IE-like option.

Opera has another solution to this problem: three image loading modes.
 1) Load and show all images; don't show alt text at all.
 2) Show already loaded images, but don't load any more.  Show alt text for
    unloaded images; preserve the specified image size even if the alt text gets
    truncated.
 3) Don't show any images.  Ignore specified image sizes, just show the complete
    alt text.

This has some advantages for power users, but IE's simpler approach is probably 
closer to our goals.  Any opinions, Ian & David?

Rewrote the summary again.  Sorry, Pierre - I guess my original report wasn't 
clear enough.
Summary: issues with broken images → Option to show alt texts even if they won't fit in image size

*** This bug has been marked as a duplicate of 34981 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
Verified Duplicate.
(Reporter)

Comment 8

17 years ago
Removing '4xp' keyword since the keyword description doesn't mention
competitor products anymore.
Keywords: 4xp
You need to log in before you can comment on or make changes to this bug.