[alarm dialog] doesn't show completely an alarm when need to slide to select it

RESOLVED FIXED in 1.0b2

Status

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: cloutier.jo, Assigned: Fallen)

Tracking

unspecified
1.0b2

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US;

with the new alarm windows when you have a lot of alarm at once and you click on one that not in the first showed (ie you need to slide to see it), I think it should completely show it.

Reproducible: Always

Steps to Reproduce:
1.create at lest 6 event in the past (one week of daily recurrent event is the easiest)
2.in the alarm windows slide down
3.select the last event you can see at the bottom
Actual Results:  
you only see half of it

Expected Results:  
you should see it completely 

it's happen only when you slide down because the space isn't switched between the first alarm at the top (that is automatically selected when alarm show up)
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/2008020921 Calendar/0.8pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 428401 [details] [diff] [review]
Fix - v1
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #428401 - Flags: review?(Mozilla)
Created attachment 429313 [details] [diff] [review]
Fix - v2

Markus found an issue with v1 where the first entry wasn't visible anymore when the dialog opens, this patch takes care.
Attachment #428401 - Attachment is obsolete: true
Attachment #429313 - Flags: review?(Mozilla)
Attachment #428401 - Flags: review?(Mozilla)
Comment on attachment 429313 [details] [diff] [review]
Fix - v2

New patch looks good and performs as expected.

r=markus
Attachment #429313 - Flags: review?(Mozilla) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/8fa3a4aefbff>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.