nsColumnSetFrame unbounded last column next in flow check is reversed

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
Layout
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Craig Topper, Assigned: Craig Topper)

Tracking

({perf})

Trunk
mozilla1.9beta4
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008020904 Minefield/3.0b4pre
Build Identifier: 

There is a section of code nsColumnSetFrame::Reflow that reads:

   // If balancing, then we allow the last column to grow to unbounded
   // height during the first reflow. This gives us a way to estimate
   // what the average column height should be, because we can measure
   // the heights of all the columns and sum them up. But don't do this
   // if we have a next in flow because we don't want to suck all its
   // content back here and then have to push it out again!
   nsIFrame* nextInFlow = GetNextInFlow();
   PRBool unboundedLastColumn = isBalancing && nextInFlow;


Based on the comment above it, I believe the last line should be:

PRBool unboundedLastColumn = isBalancing && !nextInFlow;

I don't know what symptoms this would exhibit during rendering.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

10 years ago
Created attachment 302374 [details] [diff] [review]
Patch to reverse the check
Comment on attachment 302374 [details] [diff] [review]
Patch to reverse the check

This simple think-o should speed up columns rendering significantly.
Attachment #302374 - Flags: superreview+
Attachment #302374 - Flags: review+
Attachment #302374 - Flags: approval1.9?
Assignee: nobody → craig.topper
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Keywords: perf

Updated

10 years ago
Attachment #302374 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in layout/generic/nsColumnSetFrame.cpp;
/cvsroot/mozilla/layout/generic/nsColumnSetFrame.cpp,v  <--  nsColumnSetFrame.cpp
new revision: 3.47; previous revision: 3.46
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4
You need to log in before you can comment on or make changes to this bug.