No longer seeing values getting updated automatically in Download Manager, fire proper name-changed events for ListItems.

VERIFIED WORKSFORME

Status

()

Core
Disability Access APIs
--
major
VERIFIED WORKSFORME
10 years ago
6 years ago

People

(Reporter: MarcoZ, Assigned: surkov)

Tracking

(Blocks: 1 bug, {access, regression})

Trunk
mozilla1.9beta4
x86
Windows Vista
access, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
When downloading a file, I no longer see the download status get updated automatically. I suspect that this is a regression from landing of bug 308564, but did not have time to verify that yet.
STR:
1. Start any download large enough so that you get the List in DM for a few seconds.
Expected: Values should get updated as the download progresses.
Actual: No updating occurs.
(Assignee)

Comment 1

10 years ago
It shouldn't be cause of bug 308564 because that bug was targeted on xul:tree but DM uses richlistbox.

Comment 2

10 years ago
Surkov, if you could take this one that'd be great.
Assignee: aaronleventhal → surkov.alexander
(Assignee)

Comment 3

10 years ago
Marco, I see ValueChange event from accessible for xul:progressmeter in Gecko layer. Can you give me some technical details?
(Reporter)

Comment 4

10 years ago
The progress meter is fine. The problem is in the ListItem that contains the info for the file you are currently downloading. it used to update as the kbyte blocks came in, updating the kb/sedc value and the time remaining etc.
(Assignee)

Comment 5

10 years ago
iirc value of label (as DOM node) is changed, do you mean some accessibility events are missed?
(Reporter)

Comment 6

10 years ago
Right. Last week when I was testing, and for weeks before that, I got frequent updates as I was downloading a file. This has stopped.
(Reporter)

Comment 7

10 years ago
Thiss is actually a regression resulting from fix for bug 407359. That bug converted the items of a RichListbox to ListItems. The patch landed in this build:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008012404 Minefield/3.0b3pre
Summary: No longer seeing values getting updated automatically in Download Manager. → No longer seeing values getting updated automatically in Download Manager, fire proper name-changed events for ListItems.
(Assignee)

Comment 8

10 years ago
Marco, do you have in view this?

// nsIAccessibleRole::ROLE_RICH_OPTION
- { ROLE_SYSTEM_LIST, ROLE_SYSTEM_LIST },
+ { ROLE_SYSTEM_LISTITEM, ROLE_SYSTEM_LISTITEM },
(Reporter)

Comment 9

10 years ago
Right. The LISTITEM role is appropriate, we just need to make sure the proper events get fired once the label changes.
(Assignee)

Comment 10

10 years ago
Could you look what events have been fired?
(Assignee)

Comment 11

10 years ago
Marco, I really have not idea what was worked and why it had been stoped because we do not fire name_changed event at all (excepting recent tree accessible change). It sounds the proper way to fix the bug is to watch DOM mutations and fire name changed event if corresponding node has changed. Sure it's valid only if the bug is about we don't fire name_changed event.
(Reporter)

Comment 12

10 years ago
I just did a check using DOM Inspector, and the only events I see in both builds are the ValueChanged events of the progress meter. The progress meter is a child of the LISTITEM accessible in current builds, and was the child of the LIST. Both the old LIST and the current LISTITEM are the first child of the RICHLISTBOX. So only the change from being a LIST to bein a LISTITEM makes the item not update automatically. It appears that JAWS has different handlings for when a child of a list changes versus a child of a LISTITEM.
(Assignee)

Updated

8 years ago
Blocks: 459353
(Assignee)

Comment 13

7 years ago
Marco, could you retest the bug against nightlies please?
(Reporter)

Comment 14

7 years ago
There are some updates that now happen automatically: Not while downloading, but when checking it for viruses, and when having finished that, I get updates of the accName of the accessible item. But as the download happens, it either isn't updated, or the updates happen so fast that NVDA doesn't keep up.
(In reply to comment #14)
> There are some updates that now happen automatically: Not while downloading,
> but when checking it for viruses, and when having finished that, I get
> updates of the accName of the accessible item. But as the download happens,
> it either isn't updated, or the updates happen so fast that NVDA doesn't
> keep up.

I tried downloading some big files, with nvda I saw the beeping progress meter, but no automatic reading, but that may be because nvda choose not to read with the beepy thing.  However if I explicitly reaad the entry in the list it was being updated properly.  I also tried with orca and saw aproximately the same behavior. So my gues with out digging deeper is that this all works fine.  Marco mind calling this worksforme?
(Reporter)

Comment 16

6 years ago
Not at all, this is working for me again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

6 years ago
Last tested with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110610 Firefox/7.0a1, but this also works in Firefox 4.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.