Remove All Cookies needs confirmation dialog

RESOLVED DUPLICATE of bug 210173

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 210173
11 years ago
11 years ago

People

(Reporter: tylernt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.10) Gecko/20071115 Firefox/2.0.0.10

The user is not asked to confirm whether they really want to delete ALL their cookies when clicking the Remove All Cookies button in the Preferences dialog. This leads to data loss if the user really meant to just remove the selected cookie or clicked on the button by accident.

Reproducible: Always

Steps to Reproduce:
1. Click Tools, Options, Privacy, Show Cookies
2. Click Remove All Cookies
Actual Results:  
Cookies are instantly deleted without any chance of recovery.

Expected Results:  
A confirmation should pop up and allow the user to cancel or proceed.

Similar to 308212 and 285836.

Comment 1

11 years ago
Sorry, but this is a duplicate of bug 210173, which was closed as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 210173
You need to log in before you can comment on or make changes to this bug.