Closed Bug 416960 Opened 12 years ago Closed 12 years ago

Autocomplete should be invoked after editing any part of the search query

Categories

(Firefox :: Address Bar, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 407888

People

(Reporter: asqueella, Unassigned)

References

Details

After bug 401869 landed, the users are getting used to entering multiple search terms in the location bar.

When searching using several terms, they sometimes will have to refine one of the search terms. Sometimes (unlike the old times when you entered a substring to search the URLs/titles for) it will not be the last search term. For example (I forgot the one that prompted to file me this bug, so the example is off the top of my head): you search for "bugzilla foobar", then you realize you're actually saw "foobar" in a recent e-mail and replace "bugzilla" with "gmail".

The problem is that autocomplete is only invoked when the cursor is located at the right of the location bar. Should we consider changing this?
The problem here is if the user is editing a url, it would try to show the autocomplete if we did do it for 'in-the-middle-editing'. But would that be it? We could try checking if there's multiple words and do something different.. ?
I did not think this through, but I suppose that editing in the middle of a URL could invoke autocomplete as well, provided we don't bog the browser down. In most cases there will be no autocomplete suggestions and if there are, they're probably useful [e.g. when you edit http://*en.*wikipedia.org -> http://*ru.*wikipedia.org].

If we still support auto-fill, we should be careful not to invoke it in this case, though.
OS: Windows XP → All
Hardware: PC → All
This looks like bug 407888.  Is there an equivalent for autocomplete used for forms?  Or would that also be fixed when fixing the location bar?  
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407888
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.