Last Comment Bug 416982 - cmake build system
: cmake build system
Status: RESOLVED DUPLICATE of bug 784841
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 408306
  Show dependency treegraph
 
Reported: 2008-02-12 05:21 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2013-03-20 18:52 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
zip of cmake builld stuff (129.91 KB, application/octet-stream)
2008-02-12 05:21 PST, Ted Mielczarek [:ted.mielczarek]
no flags Details

Description Ted Mielczarek [:ted.mielczarek] 2008-02-12 05:21:27 PST
Created attachment 302797 [details]
zip of cmake builld stuff

We hired a contractor to investigate implementing a CMake build system for Mozilla.  Attaching the results of his work.  I haven't actually looked at it, but it's better off here than on somebody's hard drive.
Comment 1 Brandon J. Van Every 2008-02-12 05:56:49 PST
I'm willing to advise anyone who wants to understand, utilize, or improve the code.  It is written in CMake script using lots of regular expressions.  It translates configure.in and Makefile.in files to CMake files.  For syntax, the configure.in translator is almost but not quite complete.  Semantically, there are things missing from the translation, it's not complete.  There is no tree walker either.  Last but not least it has no license statement.  I wasn't sure what Mozilla intended to do with the code.
Comment 2 Gregory Szorc [:gps] 2013-03-20 18:52:26 PDT
We decided on a new direction in bug 784841.

*** This bug has been marked as a duplicate of bug 784841 ***

Note You need to log in before you can comment on or make changes to this bug.