Enable jemalloc by default on Linux

RESOLVED FIXED in mozilla1.9beta4

Status

()

Core
Build Config
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Stuart Parmenter, Assigned: Stuart Parmenter)

Tracking

Trunk
mozilla1.9beta4
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

10 years ago
jemalloc. wee.
(Assignee)

Comment 1

10 years ago
Created attachment 302879 [details] [diff] [review]
enabling patch
OS: Windows XP → Linux
Version: unspecified → Trunk
Attachment #302879 - Flags: review+
(Assignee)

Updated

10 years ago
Flags: blocking1.9+
OS: Linux → Windows XP
Version: Trunk → unspecified
(Assignee)

Comment 2

10 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9beta4
Version: unspecified → Trunk
(Assignee)

Comment 3

10 years ago
Created attachment 302939 [details] [diff] [review]
disable jemalloc if trace-malloc is on
Attachment #302939 - Flags: review?
Attachment #302939 - Flags: review? → review+
OS: Windows XP → Linux
Comment on attachment 302939 [details] [diff] [review]
disable jemalloc if trace-malloc is on

Seems better not to silently disable -- I'd change the default of MOZ_MEMORY based on trace-malloc, but make explicitly enabling both give an error...

Comment 5

10 years ago
My build is trying to link in a static libjemalloc.a, but only the shared libjemalloc.so is being built.

gmake[5]: *** No rule to make target `../../staticlib/libjemalloc.a', needed by `firefox-bin'.  Stop.

Updated

10 years ago
Depends on: 417163

Comment 6

10 years ago
Created attachment 302998 [details] [diff] [review]
Fix static build bustage.

r=/sr=/a=pavlov on irc

Checking in Makefile.in;
/cvsroot/mozilla/memory/jemalloc/Makefile.in,v  <--  Makefile.in
new revision: 1.4; previous revision: 1.3
done
Attachment #302998 - Flags: superreview+
Attachment #302998 - Flags: review+
Duplicate of this bug: 417172
That's some 20ms Ts regression :(

Comment 9

10 years ago
This broke 64bit-Linux/Fedora7 builds, at least debug versions.
No problems in compilation, but when trying to start FF, I get the following error:
"Error: in (function call): procedure or syntax required but got: Error: fatal: looped fatal error"

I don't even know which library prints that out. Clobbering didn't help, until
I removed MOZ_MEMORY=1 from configure script.

Comment 10

10 years ago
(In reply to comment #9)
> I removed MOZ_MEMORY=1 from configure script.
--disable-jemalloc has ofc the same effect.
I cannot start Firefox trunk build without --disable-jemalloc if GTK_IM_MODULE=uim.
If it is GTK_IM_MODULE=xim, I can start fx. Should I file a new bug? And which component is suitable if I will file?
(Assignee)

Comment 12

10 years ago
file a new bug, put stacks/etc in it.

Updated

10 years ago
Depends on: 418016
Depends on: 418073

Updated

9 years ago
Depends on: 423279
Depends on: 466388
You need to log in before you can comment on or make changes to this bug.