Closed Bug 417132 Opened 12 years ago Closed 12 years ago

Firefox leaks many nsGlobalWindows with Download Statusbar installed

Categories

(Core :: General, defect, P2)

x86
macOS
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cbook, Assigned: bent.mozilla)

References

()

Details

(Keywords: memory-leak)

Attachments

(1 file)

Attached file leak log
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008020717 Firefox/3.0b4pre

Steps to reproduce:
* New Profile
* Install the Download Statusbar 
* Download something (in my case a nightly build from ftp.m.o
* Click around the Statusbar during download
--> Leak

 0 TOTAL                                          25  1752148  1078722    60893 ( 5511.94 +/-  4950.07)  2499808    59915 ( 3067.22 +/-  5216.57)


nsStringStats
 => mAllocCount:          36384
 => mReallocCount:         5534
 => mFreeCount:           30359  --  LEAKED 6025 !!!
 => mShareCount:          36464
 => mAdoptCount:           2633
 => mAdoptFreeCount:       2630  --  LEAKED 3 !!!
Flags: blocking1.9?
Summary: Firefox leaks with Download Statusbar installed → Firefox leaks many nsGlobalWindows with Download Statusbar installed
This one's looking really bad.
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Flags: tracking1.9+ → blocking1.9+
Polvi: do you have data on how commonly used this extension is? If it's a common one I think we need to keep this as a blocker since we're leaking a lot of windows here it seems.

If it's not that commonly used we might be ok with fixing it in a dot release.
(In reply to comment #2)
> Polvi: do you have data on how commonly used this extension is? If it's a
> common one I think we need to keep this as a blocker since we're leaking a lot
> of windows here it seems.
> 
> If it's not that commonly used we might be ok with fixing it in a dot release.

Very common. 6th top addon, 11188525 downloads, 1723220 daily users (3% of our user base).

Who owns this?
Peter, do you think you'll be able to take this one? Otherwise we need to find another owner.
Assignee: nobody → peterv
I'll look at this today.
Assignee: peterv → bent.mozilla
Marking as fixed. 

With the latest Version of the Extension its not leaking anymore and i guess that the latest Version and the other leak fixes we had the last weeks, we are not leaking anymore here (was only able to leak nsTArray_base, buts thats a different bug) 
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified fixed with testings on Mac OS 10.5 and Windows XP -> no leak *yeah* :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.