Closed Bug 417142 Opened 14 years ago Closed 12 years ago

make Cocoa z-level implementation more robust

Categories

(Core :: Widget: Cocoa, defect, P2)

All
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 450576

People

(Reporter: jaas, Assigned: jaas)

Details

Attachments

(1 file)

Attached patch fix v0.8Splinter Review
It would be nice to have a more robust z-level implementation for Cocoa widgets - one that keeps gecko's internal window list in the correct order all of the time and has a proper PlaceBehind impl.

See bug 404283 and in particular bug 404283 comment #7. That comment explains why the fix I have here isn't complete.
Flags: wanted1.9.2+
Priority: -- → P2
Hardware: x86 → All
Resolving as a dupe of bug 450576, which is a more helpful/specific bug.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450576
You need to log in before you can comment on or make changes to this bug.