The proto theme doesn't lighten the color of toolbars when windows backgrounded

RESOLVED DUPLICATE of bug 406730

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 406730
11 years ago
11 years ago

People

(Reporter: blassey, Assigned: blassey)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 302999 [details] [diff] [review]
changes the color on focus

Native windows lighten in color when ever they are not the top most window.  Because firefox with the proto theme does not, users can be confused as to which window has focus.
Attachment #302999 - Flags: review?(mconnor)
Attachment #302999 - Flags: approval1.9?
(Assignee)

Comment 1

11 years ago
This patch is changing colors (and image) based on focus and blur events.  It would probably be better if there was an event specific to the window being sent to the background and foreground.  Does that exist?
Status: NEW → ASSIGNED
Attachment #302999 - Flags: review?(mconnor)
Attachment #302999 - Flags: review?(mano)
Attachment #302999 - Flags: approval1.9?
Comment on attachment 302999 [details] [diff] [review]
changes the color on focus

This shouldn't be done on the theme level (there is an ancient bug about disallowing setting attributes like this on theme bindings).

I think the right way to fix this is to first 
move the binding to browser/base/content (and apply it from pinstripe), then also use  real <handler> elements for this.
Attachment #302999 - Flags: review?(mano) → review-
I think we're in the process of uncrippling themes, we made an explicit choice to stop trying to preserve some sort of "safe" theme framework a while back, but I don't know if we've explicitly declared as such, but this patch should be acceptable now.
(Assignee)

Comment 4

11 years ago
Created attachment 303044 [details] [diff] [review]
changes the color of the toolbar (for when there is no backgroudn image)
Attachment #303044 - Flags: review?
(Assignee)

Comment 5

11 years ago
Apologies, I just realized there was a second change to browser.css.  Without it, things probably look funny.

(Assignee)

Comment 6

11 years ago
Created attachment 303049 [details] [diff] [review]
changes the color of the toolbar (for when there is no backgroudn image)
Attachment #303044 - Attachment is obsolete: true
Attachment #303044 - Flags: review?
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406730
You need to log in before you can comment on or make changes to this bug.