some menus way to tall (whole screen), some way too short (2-3 px)

RESOLVED DUPLICATE of bug 410881

Status

()

defect
RESOLVED DUPLICATE of bug 410881
12 years ago
12 years ago

People

(Reporter: dsnopek, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008020513 Firefox/3.0b3

I'm using the binary build I downloaded via links on this page (http://developer.mozilla.org/devnews/index.php/2008/02/12/firefox-3-beta-3-now-available-for-download/).

This is concerning the menu bar on the main browser window.  Clicking on some labels (File, Edit, View, Bookmarks, Tools) will show a menu that is 2-3 pixels tall, with no visible items.  Clicking other labels (History, Help) will show a menu that goes all the way to the bottom of the screen.  I also appear to be able to hit the down arrow at the bottom of the big menus and scroll away for an indeterminate period of time.

I'm going to attempt to attach some screen shots that can show this most clearly.

I'm running Debian Etch with the Ion windowing manager.


Reproducible: Always

Steps to Reproduce:
1. Simply click an label on the menubar!
Here I clicked on the File label on the menubar, and it show the super short menu with no visible items directly below it.
Here I clicked the "History" label on the menubar, and it shows a menu which stretches all the way to the bottom of the screen (in fact, past the borders of the browser window, although thats hard to tell from this screenshot).

Also, if i click the down arrow at the bottom of the window, it will scroll the visible items on top away so I can't see any items.  Clicking the top arrow will scroll them back in.  I assume this is also incorrect behavior but I don't really know.
I assume this is "Trunk"?  Certainly none of the other version tags apply.  I'm using Firefox 3 beta 3.
Version: unspecified → Trunk
It appears that this bug is entirely related to using Gtk 2.8.  I just manually compiled and installed Gtk 2.12.6 (Debian Etch includes 2.8.20) and the problem goes away!

Bug 418885 discusses the greater-than Gtk 2.10 requirement.

Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410881
You need to log in before you can comment on or make changes to this bug.