Bookmark cannot handle %2B ('+' sign) when accessed by its tag

VERIFIED FIXED in Firefox 3 beta5

Status

()

Firefox
Address Bar
P2
major
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Michael Schonfeld, Assigned: Mardak)

Tracking

Trunk
Firefox 3 beta5
Points:
---
Bug Flags:
blocking-firefox3 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has fix in bug 419656], URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre

When you bookmark a page with a %2B (the plus sign) in the URL, and then reload it using a tag: instead of loading "...=blocking-firefox3%2B", it loads "...=blocking-firefox3+", which in turn leads to an error page.

Reproducible: Always

Steps to Reproduce:
1. Goto https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&resolution=DUPLICATE&resolution=---&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=flagtypes.name&type0-0-0=equals&value0-0-0=blocking-firefox3%2B	- And bookmark it using CMD+D. Also, apply tag: "block".
2. Hit "block" in the AwesomeBar, and press the first result (the page we just bookmarked)
Actual Results:  
Loads the url with "...blocking-firefox3+" at the end of the URL, which returns the "Zarro Boogs found." page!

Expected Results:  
Load the original URL with "...blocking-firefox3%2B" at the end of the URL, which will return a list of firefox3-blocker bugs.

Note that this only occurs when loading the bookmark using the "block" tag. When I try to load the bookmark from the Bookmarks menu, it loads just fine. Also, the bookmark *IS* saved correctly (check the library), its just not loaded correctly.

This leads me to believe that its a bug of the tagging service.
(Reporter)

Updated

10 years ago
Flags: blocking1.8.1.13?
Component: Bookmarks → Places
Flags: blocking1.8.1.13?
QA Contact: bookmarks → places
Summary: Bookmark cannot handle %2B ('+' sign) when accessed by it's tag → Bookmark cannot handle %2B ('+' sign) when accessed by its tag
Version: unspecified → Trunk
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
I'm pretty sure that this is a dupe ...
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P2
Whiteboard: DUPEME
Haven't seen a dupe of this, Edward, this really sucks...
Assignee: nobody → edilee
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

10 years ago
This will be fixed by bug 419656 so that we don't unescape things in the backend but do it safely in the front-end.
Status: NEW → ASSIGNED
Component: Places → Location Bar and Autocomplete
Depends on: 419656
OS: Mac OS X → All
QA Contact: places → location.bar
Hardware: Macintosh → All
Whiteboard: DUPEME → [has fix in bug 419656]
(Assignee)

Comment 4

10 years ago
Created attachment 306956 [details] [diff] [review]
testcase v1

Testcase changes that will land when bug 419656 is fixed.
(Assignee)

Comment 5

10 years ago
Checking in toolkit/components/places/tests/unit/test_416214.js;
/cvsroot/mozilla/toolkit/components/places/tests/unit/test_416214.js,v  <--  test_416214.js
new revision: 1.3; previous revision: 1.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta5
Verified FIXED using:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008050904 Minefield/3.0pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050904 Minefield/3.0pre

-and-

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9pre) Gecko/2008050906 Minefield/3.0pre

using the steps in comment 0.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.