All users were logged out of Bugzilla on October 13th, 2018

back button history menu always goes back one page

VERIFIED DUPLICATE of bug 415444

Status

()

--
major
VERIFIED DUPLICATE of bug 415444
11 years ago
11 years ago

People

(Reporter: peter.kidwell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

When I click-and-hold on the back button in the main toolbar, to pop up the history menu, FF 3.0b3 always goes back exactly one page (as if I had simply clicked the back button) no matter what item from the menu is chosen. Choosing the page from the "History" menu in the main menubar works fine.

This did not occur with FF 3.0b2.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox and display your home page.
2. Click some link to go to "Page A", then click another link to go to "Page B".
3. Click and hold the back button to pop up the history menu, and choose the original home page.
Actual Results:  
Firefox goes back to "Page A".

Expected Results:  
Firefox should go back to the chosen page (the home page).

Using theme Proto 0.11.
(In reply to comment #0)
> This did not occur with FF 3.0b2.

And won't with b4, it just missed b3 by a day.

> Using theme Proto 0.11.

It's the default theme now, so you're better off switching to it-as-default instead of it-as-extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415444
Verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

11 years ago
Apologies for the dupe, I didn't think the first one went through...
You need to log in before you can comment on or make changes to this bug.