If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Download dbghelp.dll from Microsoft during installation

RESOLVED WONTFIX

Status

()

Firefox
Installer
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Andrés Delfino, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Bug Flags:
blocking-firefox3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.6) Gecko/20070819 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8.1.6) Gecko/20070819 Firefox/2.0.0.6

Installer for Windows 2000 should download dbghelp.dll from Microsoft to have a functional Breakpad, other way, it's useless in that platform.

The file is distributed here:
http://www.microsoft.com/whdc/devtools/debugging/installx86.mspx

Reproducible: Always
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382124
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Per bug 382124 this is a wontfix. Please do not clear resolutions without a comment explaining why you believe the resolution is incorrect.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382124
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> Per bug 382124 this is a wontfix. Please do not clear resolutions without a
> comment explaining why you believe the resolution is incorrect.
> 
> *** This bug has been marked as a duplicate of bug 382124 ***
> 

This is not a duplicate of bug 382124, and while that bug mentions the idea proposed here, nobody answered about it.

WONTFIX comment for bug 382124 refeers to comments comments 17 and 19. Neither of the two deals with the idea proposed here.

Please, WONTFIX this, instead of resolved duplicate, if you don't like the proposed way of dealing with the breakage.
(Reporter)

Updated

10 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
The complexity of adding a mechanism to the installer which goes out to Microsoft's servers and fetches dbghelp.dll isn't worth it. We're not going to do this for that reason. This bug is also a WONTFIX, but I'll let bsmedberg say so.

Comment 5

10 years ago
My tendency would be to take a patch if it were simple enough, but that may not be practical. rstrong, can you WONTFIX this if you think it's too complicated to even take a contributed patch?
(Reporter)

Updated

10 years ago
Severity: major → enhancement
Summary: Installer for Windows 2000 should download dbghelp.dll from Microsoft to have a functional Breakpad → Make installer for Windows 2000 download dbghelp.dll from Microsoft
(Reporter)

Updated

10 years ago
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3-
That sounds like it would depend on the patch, no?

Comment 7

10 years ago
Well, there's a minimum complexity required, such as an NSIS plugin to download a file, and security concerns. If rstrong doesn't want to maintain that functionality, this is WONTFIX.
(Reporter)

Updated

10 years ago
Summary: Make installer for Windows 2000 download dbghelp.dll from Microsoft → Download dbghelp.dll from Microsoft in installer for Windows 2000
(Reporter)

Updated

10 years ago
Summary: Download dbghelp.dll from Microsoft in installer for Windows 2000 → Download dbghelp.dll from Microsoft in installer
(Reporter)

Updated

10 years ago
Summary: Download dbghelp.dll from Microsoft in installer → Download dbghelp.dll from Microsoft during installation
(Reporter)

Comment 8

10 years ago
(In reply to comment #6)
> That sounds like it would depend on the patch, no?
> 

By definition, a blocker does not depend on a patch.
Please stop spamming this bug with small changes to the description.
(In reply to comment #7)
> Well, there's a minimum complexity required, such as an NSIS plugin to download
> a file, and security concerns. If rstrong doesn't want to maintain that
> functionality, this is WONTFIX.
I definitely don't want the additional complexity.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
Blocks: 382124
You need to log in before you can comment on or make changes to this bug.