Upload of PDF arrives with mime type "application/other"

RESOLVED DUPLICATE of bug 373621

Status

()

RESOLVED DUPLICATE of bug 373621
11 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

I am uploading a pdf file via a form to a linux/apache/php application. The application identifies the upload as mime type "application/other." Since file upload validation is being used, it's rejecting the file because it's not of type "application/pdf." Is this likely a browser issue or server issue, and how can I fix it?

Reproducible: Always

Steps to Reproduce:
1. Select pdf file to upload
2. Submit form
3.
Actual Results:  
Error message from PHP application.

Expected Results:  
Success message from PHP application.
A browser issue, with the file mimetypes.rdf in your profile, but as you've seen you'll get better support from http://support.mozilla.com/ than by filing a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621
You need to log in before you can comment on or make changes to this bug.