If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Extend default cookie expiration from 2 to 10 years

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
10 years ago
5 years ago

People

(Reporter: baz, Assigned: oremj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Waiting on omniture., URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
The current Omniture "opt out cookie" is set to expire in 2010. Let's set it to something a bit longer like 2018.

Since this site I believe is maintained by Omniture, we may need to send the request to them.
(Reporter)

Comment 1

10 years ago
Assigning to Jeremy to ensure we don't lose track of this.
Assignee: nobody → oremj
(Assignee)

Comment 2

10 years ago
Sent e-mail to Caleb.
(Assignee)

Comment 3

10 years ago
He replied.  I just need to set s.cookieLifetime=315360000 in the javascript.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Blocks: 415275
Created attachment 337789 [details]
Screenshot of omniture_optout cookie
Am I looking at the wrong thing?  This doesn't seem fixed to me, since the cookie's expiration date is still only two years out--2010.
(Reporter)

Comment 6

9 years ago
Created attachment 337830 [details]
2010 cookie expiration

I can confirm what Stephen is seeing as well - looks like the cookie is expiring in 2010 not 10 years per the request. Re-opening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

9 years ago
I've pushed the change to prod and it should be live within the next hour.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago9 years ago
Resolution: --- → FIXED
I don't want to jump the gun, but I'm still seeing the cookie's value set at 2010, and it's a couple hours later -- has some cron job just not yet run?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

9 years ago
It's working for me.  Did you clear your existing cookies?
(Reporter)

Comment 10

9 years ago
I can verify that this is not working for me either. I checked that I have no "
cookies with "opt" in the string. Installed the opt out cookie and it shows 2010.
(Assignee)

Comment 11

9 years ago
Still waiting for omniture to respond.
(Assignee)

Updated

9 years ago
Whiteboard: Waiting on omniture.

Comment 12

9 years ago
Omniture says that the timing for the opt-out cookie expiration is 2 years and can't be changed (e.g., to 10 years as Basil had requested).

Is this a problem for us?
(Reporter)

Comment 13

9 years ago
We never mention the length of expiration of the cookie on any of our web pages but in the discussion we had in mozilla.governance, we stated that we would do that. So, it's a tacit commitment. On the other hand, if it can't be done - then what? We can 1) pressure Omniture or 2) live with it or 3) toss out Omniture. :-)
(Assignee)

Comment 14

9 years ago
Omniture says this this not possible.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WONTFIX
(In reply to comment #13)
> We never mention the length of expiration of the cookie on any of our web pages
> but in the discussion we had in mozilla.governance, we stated that we would do
> that. So, it's a tacit commitment. On the other hand, if it can't be done -
> then what? We can 1) pressure Omniture or 2) live with it or 3) toss out
> Omniture. :-)

Actually, we do on http://www.mozilla.com/en-US/opt-out.html, so I've filed bug 461608 to deal with that.
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.