seamonkey crashes at start with "free(): invalid pointer:" in libgtk (using gtk2 2.8.11)

RESOLVED DUPLICATE of bug 406140

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 406140
10 years ago
10 years ago

People

(Reporter: craig harmer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007083101 SeaMonkey/2.0a1pre
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/seamonkey-2.0a1pre.en-US.linux-i686.tar.bz2

seamonkey crashes at startup with a free error.  the first part of the stack trace looks like:

charmer@bigblack[mozilla]/local/lib/seamonkey/seamonkey

(Gecko:4987): Gtk-WARNING **: gtkwidget.c:7306: widget class `GtkButton' has no property named `inner-border'
*** glibc detected *** /local/lib/seamonkey/seamonkey-bin: free(): invalid pointer: 0xb5e2e996 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7561cb1]
/lib/libc.so.6(__libc_free+0x84)[0xb7563314]
/opt/gnome/lib/libglib-2.0.so.0(g_free+0x22)[0xb785a892]
/opt/gnome/lib/libgtk-x11-2.0.so.0(IA__gtk_border_free+0x1d)[0xb7bb9c6d]
/local/lib/seamonkey-20080215/components/libwidget_gtk2.so[0xb5e2e9d4]
/local/lib/seamonkey-20080215/components/libwidget_gtk2.so[0xb5e30b56]
/local/lib/seamonkey-20080215/components/libwidget_gtk2.so[0xb5e5143c]
/local/lib/seamonkey-20080215/components/libgklayout.so[0xb469e28d]
/local/lib/seamonkey-20080215/components/libgklayout.so[0xb469f387]

this is with the 20080215 download that i just picked up.  it did not occur with the 20080201 download (although that crashed quickly due to a bug someone else has reported).

note that i am running "down level" versions of many of the libraries.  in particular:

gtk2-2.8.11-0.15
gtk2-engines-2.6.7-17.2
pango-1.10.2-23.2
pango-devel-1.10.2-23.2

this is all on a Suse Linux Enterprise Desktop system.

seamonkey doesn't actually exit after this occurs.  instead it seems to hang until i press ^C.

Reproducible: Always

Steps to Reproduce:
1. start seamonkey from the command line or button
2. 
3.
Actual Results:  
seamonkey doesn't start (nothing appears on the screen).  if i start it from the command line, i get to see voluminous output about the problem.

Expected Results:  
i expected to see the Seamonkey home page.

this is Suse Linux Enterprise Destkop 10.1 system, so the libraries are not up to the latest required versions (and it's not so easy to upgrade them).  Note that this is the latest supported version of Suse Linux Enterprise.

if you're not seeing this with current libraries on the latest version of Suse Linux (the pur open source version) then you might want to close this with an "upgrade your computer".
(Reporter)

Comment 1

10 years ago
Created attachment 303606 [details]
Complete stack trace and memory map for free error.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 406140
You need to log in before you can comment on or make changes to this bug.