Status

SeaMonkey
Installer
P3
blocker
VERIFIED DUPLICATE of bug 36781
18 years ago
13 years ago

People

(Reporter: Matthew Dean, Assigned: Samir Gehani)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; U; Linux 2.2.15 i586)
BuildID:    060620

When using ./mozilla-installer it crash's during installation.
sometimes when using --sync i get an async error and it seems to freeze the
program and not segfault.


Reproducible: Always
Steps to Reproduce:
1. run ./mozilla-installer
2. type run --sync
3. Select typical installation
4. click OK

Actual Results:  When it says Installing Mail & News... It says Processing file
164 of 164 and crash's.
./libzlib.so: No such file or directory.
nNCL: registering deferred (0)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 1026 (runnable)]
0x80ee9c0 in ?? ()
(gdb) bt 
#0  0x80ee9c0 in ?? ()
#1  0x4044c453 in ?? ()
#2  0x4045bdc0 in ?? ()
#3  0x40261f5f in __pthread_destroy_specifics () at specific.c:145
#4  0x4025eda3 in pthread_exit (retval=0x0) at join.c:36
#5  0x805352b in nsInstallDlg::WorkDammitWork ()
#6  0x4025f5d7 in pthread_start_thread (arg=0xbf7ffe40) at manager.c:241
#7  0x4025f614 in pthread_start_thread_event (arg=0xbf7ffe40) at manager.c:264


Expected Results:  Installed mozilla and not crash? :)

I did notice I dont have the following librarys reported as not being found by
gdb:

./libplds4.so: No such file or directory.
./libplc4.so: No such file or directory.
./libnspr4.so: No such file or directory.
./libxpcom.so: No such file or directory.
./libjsdom.so: No such file or directory.
./libzlib.so: No such file or directory.
 I have zlib 1.1.3 as a shared library but compiled as 
/usr/local/lib/libz.so.1.1.3

I get the same stack trace if i do custom for any of the programs.

Comment 1

18 years ago
reassigning to Samir.
Assignee: ssu → sgehani
(Assignee)

Comment 2

18 years ago
Remote display or are you on the host terminal?  What build?  Also, please see 
bug 36781 to determine if this is a dup.  Thanks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

18 years ago
And BTW, if you look at the mozilla-installer shell script, it already runs 
./mozilla-installer-bin --sync.
(Reporter)

Comment 4

18 years ago
It's similiar as 36781 with the async problem, however I dont have remote
displays, I run X on the same machine as the display. As for bug 36781, I dont
"Get these "cannot unlink" and "cannot remove directory" msgs (for .tmp 
directories)." I modified the script so i can run gdb as well, exec gdb
./mozilla-installer, and then i type run --sync which is the correct syntax for
running mozilla-installer-bin --sync. It reproduces same error with or without
gdb and with or without the script modificationk, the same problem still
occurs.I went ahead and did a diff test like in bug 36781

cx543622-a:~/moz2$ diff package /usr/local/mozilla
Only in package: TestGtkEmbed
Only in package: bloaturls.txt
Common subdirectories: package/chrome and /usr/local/mozilla/chrome
Binary files package/component.reg and /usr/local/mozilla/component.reg differ
Common subdirectories: package/components and /usr/local/mozilla/components
Common subdirectories: package/defaults and /usr/local/mozilla/defaults
Common subdirectories: package/icons and /usr/local/mozilla/icons
Only in package: libgtkembedmoz.so
Only in package: mozilla-config
Only in package: mozilla-installer-bin
Only in package: nsTestSample
Common subdirectories: package/plugins and /usr/local/mozilla/plugins
Common subdirectories: package/res and /usr/local/mozilla/res
Common subdirectories: package/searchplugins and
/usr/local/mozilla/searchplugins
Only in package: timebombgen
Only in package: vreg
Only in package: xpidl
Only in package: xpt_dump
Only in package: xpt_link

It doesn't exactly look like bug 36781, but a few similiarties.
I tested it witht todays build 2000060708
(Assignee)

Comment 5

18 years ago
RH 6.2 stock installation, I take it?  Hardware specs?

Grace,
Can you reproduce this on a RedHat 6.2 Linux configuration?
Target Milestone: --- → M17
(Reporter)

Comment 6

18 years ago
System Config
-----------------
XFree86 Version 4.0 / X Window System
(protocol Version 11, revision 0, vendor release 6400)
Release Date: 8 March 2000

Device "Creative Graphics Blaster TNT2"
Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz

NV: driver for NVIDIA chipsets: RIVA128, RIVATNT, RIVATNT2,
        RIVATNT2 (Ultra), RIVATNT2 (Vanta), RIVATNT2 M64,
        RIVATNT2 (Integrated), GeForce 256, GeForce DDR, Quadro

NVIDIA_GLX.0.9

Window Maker 0.62.1

64MB ram, k6-2 300mhz, Linux 2.2.15, Slackware 7

Not default stock Slack, current binaries have been updated

gcc 2.95.2

GLIBC 2.1.3

Additional librarys:
audiofile-0.1.9
bzip2-1.0.0
giflib-4.1.0
glib-1.2.8
gtk+-1.2.8
imlib-1.9.8.1
jpeg-6b
lesstif-0.91.0
libPropList-0.10.1
libpng-1.0.6
libsigc++-0.8.5
libuta-0.3.24
libxml-1.8.7
tiff-v3.4
xpm-3.4k
zlib-1.1.3

dmesg output:
Linux version 2.2.15 (root@cx543622-a) (gcc version 2.95.2 19991024 (release)) #
4 Fri Jun 2 14:58:10 PDT 2000
Detected 300687939 Hz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 599.65 BogoMIPS
Memory: 63112k/65536k available (1096k kernel code, 416k reserved, 868k data, 44
k init)
Dentry hash table entries: 8192 (order 4, 64k)
Buffer cache hash table entries: 65536 (order 6, 256k)
Page cache hash table entries: 16384 (order 4, 64k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: L1 I Cache: 32K  L1 D Cache: 32K
CPU: AMD AMD-K6(tm) 3D processor stepping 00
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xfb250
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: 00:38 [1106/0586]: Work around ISA DMA hangs (00)
Activating ISA DMA hang workarounds.
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 65536 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5 
Detected PS/2 Mouse Port.
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.12)
Real Time Clock Driver v1.09
Sound initialization started
Sound initialization complete
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:pio, hdb:pio
ide0: VIA Bus-Master (U)DMA Timing Config Success
    ide1: BM-DMA at 0xe008-0xe00f, BIOS settings: hdc:pio, hdd:pio
ide1: VIA Bus-Master (U)DMA Timing Config Success
hda: WDC AC36400L, ATA DISK drive
hdc: ATAPI CD-ROM DRIVE 32X MAXIMUM, ATAPI CDROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: WDC AC36400L, 6149MB w/256kB Cache, CHS=784/255/63, UDMA
hdc: ATAPI 27X CD-ROM drive, 120kB Cache
Uniform CDROM driver Revision: 2.56
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth0: Digital DC21041 Tulip rev 33 at 0xe800, 00:00:C5:47:A5:60, IRQ 10.
eth0: 21041 Media table, default media 0800 (Autosense).
eth0:  21041 media #0, 10baseT.
eth0:  21041 media #4, 10baseT-FD.
eth1: Lite-On 82c168 PNIC rev 32 at 0xec00, 00:A0:CC:58:34:B7, IRQ 9.
eth1:  MII transceiver #1 config 3000 status 7809 advertising 01e1.
Partition check:
 hda: hda1 hda2 < hda5 > hda3
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 44k freed
Adding Swap: 128484k swap-space (priority -1)
VFS: Disk change detected on device ide1(22,0)
eth0: 21143 10baseT link beat good.
ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
Found OPL3-SAx (YMF719)
<MS Sound System (CS4231)> at 0x534 irq 5 dma 0,3
<MPU-401 0.0  Midi interface #1> at 0x330 irq 5 dma 0,0
NVRM: **** Verifying we have an AGP graphics card
NVRM: *** found AGP device at slot 0x0
NVRM: *** init AGP
NVRM: *** init chipsets
NVRM: *** unrecognized AGP chipset, not configuring

if anyone is interested in seeing my XFree86.0.log file and/or XF86Config,
Kernel Config File, or any /proc files, please email me since these files are
quite lengthy :)
I've tried changing video drivers, window managers, same error occurs. It
appears to install the Navigator and Mail and news, however chatzilla never gets
installed. It appears to run fine however I haven't done extensive testing other
than running it, opening mail, and changing to www.yahoo.com.
(Assignee)

Comment 7

18 years ago
Grace,
Never mind what I said about testing on an RH 6.2 system.  When you get a chance 
please reproduce this in our labs on a Slackware 7 system.  Thanks.
Status: NEW → ASSIGNED

Comment 8

18 years ago
Adding crash keyword.
Keywords: crash
(Assignee)

Comment 9

18 years ago
Matthew,
I have been given to understand that it may be the case we don't QA the 
Slackware 7 platform.  In addition, I am not equipped with sucha a configuration 
to debug.  In order to resolvethis, I am open to patches for the bug.  Let's see 
if Grace comes up with a Slackware 7 machine.

Comment 10

18 years ago
Not sure if I am seeing the same thing- on first attempt at install I get the 
following error.
Xlib: unexpected async reply (sequence 0x3c90)!
and install hangs.

A second attempt is successful as in the past (coredump at finish)
(Reporter)

Comment 11

18 years ago
I do recieve that same error, however it appears to happen randomly and not
every time, however, I dont remember it ever happening without using --sync, but
i could be mistaken.
(Reporter)

Comment 12

18 years ago
Oh, on another note, does it infact install Chatzilla as well? I try mozilla
-chat but the browser just comes up, and there's nothing chat related under
tools..or anything resembling the word "chat" in the mozilla directory, find
/usr/local/mozilla | grep "chat" or find /usr/local/mozilla | grep "Chat"

Comment 13

18 years ago
now that you mention it- I do not see it being installed and checked directories 
and it is not part of installed build...part of gunzipped build though

sgehani, granrose-shouldn't chatzilla be part of this installed build?

Comment 14

18 years ago
dunno. if you do a custom install, it shows chatzilla as an option, but I've 
never tried to use it after installation.

cc'ing leaf for his input.
(Assignee)

Comment 15

18 years ago
Yes, chatzilla should be part of this install.  Dan added it XP.  CC'ing him.

Comment 16

18 years ago
color me blind! chatzilla available in custom install 
Hmm, does that mean chatzilla is not part of the typical installation? I made 
it part of typical on the windows and mac mozilla builds, probably should be on 
Linux as well.

Comment 18

18 years ago
Linux currently has the 4 options, Typical (most common options, without Java), 
Complete (with Java), Navigator only, and Custom.
(Assignee)

Comment 19

18 years ago
Two things:
1> The chatzilla/options discussion is way off topic.  Let's leave that out of 
this bug.
2> The options in mozilla are all lies right now.  I'll be fixing this to remain 
in line with the commercial options: typical and custom.  While doing this I'll 
add chatzilla to typical.
(Reporter)

Comment 20

18 years ago
This bug still seems to exist. I just did a clean install of Slackware 7.1 and
the backtrace is still the same.
#0  0x405217ef in ?? ()
#1  0x4042e453 in ?? ()
#2  0x4043ddc0 in ?? ()
#3  0x4025ef5f in __pthread_destroy_specifics () at specific.c:145
#4  0x4025bda3 in pthread_exit (retval=0x0) at join.c:36
#5  0x805352b in nsInstallDlg::WorkDammitWork ()
#6  0x4025c5d7 in pthread_start_thread (arg=0xbf7ffe40) at manager.c:241
#7  0x4025c614 in pthread_start_thread_event (arg=0xbf7ffe40) at manager.c:264
BuildID: 2000071211
It crashed on a Typical Install after installing file 54 of 54 of Chatzilla.
What Glibc version are you guys using? I'm running Glibc 2.1.3, is it possible
it's a pthread bug?


Status: ASSIGNED → NEW
(Reporter)

Comment 21

18 years ago
Okay, I went ahead and compiled it on my Slack71 i'm running with Debug
information and here's what I got and the same backtrace btw:
progress percent: 0.977143      aVal: 171       aMax: 175
progress percent: 0.982857      aVal: 172       aMax: 175
progress percent: 0.988571      aVal: 173       aMax: 175
progress percent: 0.994286      aVal: 174       aMax: 175
progress percent: 1.000000      aVal: 175       aMax: 175
DEBUG: XPI_Install mail.xpi returned 0
nsXIEngine.cpp 428: XPI_Exit called 
nsXIEngine.cpp 51: ~nsXIEngine 
nsXIEngine.cpp 55:  
nsInstallDlg.cpp 331: pre pthread_exit 
./mozilla-installer: line 48: 32730 Segmentation fault     
./mozilla-installer-bin --sync

Let me know if this helps any
(Assignee)

Comment 22

18 years ago
Debugging the problem on Linux yielded exactly the same results.  This looks 
like a dup of 36781.

*** This bug has been marked as a duplicate of 36781 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 23

18 years ago
Please note that I'm not using a remote display or rlogin, I'm at the same
machine X is running on.
(Assignee)

Comment 24

18 years ago
Yes, bug 36781 has morphed into a problem that manifests on local displays too.

Comment 25

18 years ago
verify
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.