Selecting a mail should clear/blank the mail pane

NEW
Unassigned

Status

19 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
It seems to me that when you select a mail, Mozilla tries load the mail 
content and display it. But before this Mozilla should clear/blank the mail
pane before reading the mail content.
Otherwise if it's a large mail, the content of the previous selected mail still 
it visible in the mail pane.

Comment 1

19 years ago
I think this might be a dup of another bug.
Target Milestone: --- → M18

Comment 2

19 years ago
cc'ing mscott. We used to do this I think, but I think it's a big performance
hit to do this.  marking won't fix.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

19 years ago
"big performance hit"? To clear the pane??? This I dont understand. Please 
explain...
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 4

19 years ago
Yes it did hurt our message loading speed because we would do a full repaint to 
blank out the screen then another repaint to re-layout the message. 

reclosing. this is a dead snake.
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

19 years ago
He, he.. to me (non c++ coder) doing a blanking doesn't seems to be the most 
timeconsuming task...:)
It's kind of sad, since being able to see the "old" mail while loading a new is 
kind of bad and ugly....
(Reporter)

Comment 6

18 years ago
Doing more and more operations on Mozilla I really miss this feature. After I 
delete a mail, it's really hard to see which mail is selected.

To reproduce:
0) Have to HTML mails with HTML and images
1) Select the first HTML mail
2) The mail takes a while to load in the message pane because of HTML and images
3) Press the DEL to delete the mail
4) The thread pane removes the mail right away and selects the next message
5) But looking at the message pane the first mail is still showing because of 
the load time of HTML mails and some users might press DEL another time.
Status: RESOLVED → REOPENED
OS: Windows 2000 → All
Hardware: PC → All
Resolution: WONTFIX → ---

Updated

18 years ago
Target Milestone: M18 → ---
Product: Browser → Seamonkey
No comments since more than seven years. Is anyone still interested in this bug? If no one is willing (and able: I'm not) to fix it, well, then it WONT get FIXed... and then we could just as well RESOLVE it as such.
I suppose that after seven years of hardly any action, this bug's A+QA could just as well be reset to default.
Assignee: scottputterman → mail
Status: REOPENED → NEW
QA Contact: lchiang
Assignee: mail → nobody
Priority: P3 → --
QA Contact: message-display
You need to log in before you can comment on or make changes to this bug.