Don't selecting the result where the mouse can be found when working with keyboard

VERIFIED DUPLICATE of bug 408723

Status

()

VERIFIED DUPLICATE of bug 408723
11 years ago
11 years ago

People

(Reporter: nikosverschore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre

I (like many others) work a lot with the keyboard and your mouse stands mostly somewhere in the middle of the screen doing nothing. But if you then use the location bar and type some search term, the entry that is located under the mouse is selected.
That's normal behavior, but not desired behavior. if I don't use my mouse and i'm busy typing, I want the top result on enter, not the XXX where my mouse is standing.

So my mouse position must only be taken into account for selecting the result, when I already have moved my mouse.

Reproducible: Always

Steps to Reproduce:
1. Put you mouse in the middle of the screen
2. ctrl-t (new tab)
3. type mozilla.com
4. hit enter
Actual Results:  
Opens the Xth result.

Expected Results:  
Opens the first result.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 408723

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.