Resizing Chatzilla window does not auto scroll text

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: wd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: may require changes to XUL to implement)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m16) Gecko/20000606
BuildID: 2000060622

When the Chatzilla window is made smaller, the bottom of the message window text
is not visible. (The most recent messages)

Reproducible: Always
Steps to Reproduce:
1.Open Chatzilla
2.Join a chatroom and wait for the message window to start to fill
3.Resize the Chatzilla window to make it smaller

Actual Results: The most recent messages on the bottom are pushed off the window
as it becomes smaller.

Expected Results: The last line of text is always visible.

The user should never have to manually move the scrollbar down to make the last
message visible after resizing the window. It should be scrolled automatically.

Comment 1

19 years ago
mass accepting chatzilla bugs and marking "future"
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

18 years ago
*MASS SPAM*

Changing QA contact on all open or unverified ChatZilla bugs to me, David
Krause, as I am now the QA contact for this component.
QA Contact: rginda → David

Comment 3

18 years ago
I'm not sure this is possible.  I agree it would be a good thing, but xul
doesn't provide an onresize to windows.  Marking invalid for now.  If anyone
knows something different, please say so.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
Reopening bug, since it is valid, even though architectural problems make it 
hard to implement.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Reassigning to nobody to keep this bug off rginda's radar.
Assignee: rginda → nobody
Status: REOPENED → NEW
Keywords: helpwanted
Whiteboard: may require changes to XUL to implement

Updated

18 years ago
Target Milestone: Future → ---

Comment 6

18 years ago
it looks like there is an onresize event for the window now.
Status: NEW → ASSIGNED
Keywords: helpwanted

Updated

18 years ago
Depends on: 71468

Comment 7

18 years ago
superbug checked in, mass marking all dependents fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.