Applets crash the browser in linux with 1.6 JDK [@ libjavaplugin_nscp.so] [@ ProxyJNIEnv::ProxyJNIEnv]

RESOLVED INCOMPLETE

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED INCOMPLETE
10 years ago
6 years ago

People

(Reporter: aravind, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Linux
crash, testcase

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

10 years ago
I am using the latest trunk in linux (debian sid).  I have the latest jdk from SUN (1.6.0_04-b12).  I can get the applets to work sometimes, but it still crashes within a minute on some applets.  To re-create, try some of the applets from the url.

The 1.4.2_16-b05 JDK doesn't seem to have this problem.

Here is a crash report bp-34efcf07-dca5-11dc-86e0-001a4bd43ed6
Component: General → Java: OJI
Product: Firefox → Core
QA Contact: general → java.oji
0  	libjavaplugin_nscp.so@0x1513d  	
1 	libjavaplugin_nscp.so@0xe492 	
2 	libjavaplugin_oji.so@0xf025 	
3 	ProxyJNIEnv::ProxyJNIEnv(nsIJVMPlugin*, nsISecureEnv*) 	mozilla/modules/oji/src/ProxyJNI.cpp:1724
4 	CreateProxyJNI(nsIJVMPlugin*, nsISecureEnv*) 	mozilla/modules/oji/src/ProxyJNI.cpp:1744
5 	JVM_GetJNIEnv 	mozilla/modules/oji/src/jvmmgr.cpp:289
6 	nsJVMManager::GetProxyJNI(JNIEnv_**) 	mozilla/modules/oji/src/nsJVMManager.cpp:173
7 	nsPluginHostImpl::TrySetUpPluginInstance(char const*, nsIURI*, nsIPluginInstanceOwner*) 	mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp:4003
8 	nsPluginHostImpl::SetUpPluginInstance(char const*, nsIURI*, nsIPluginInstanceOwner*) 	mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp:3880
9 	nsPluginHostImpl::InstantiateEmbeddedPlugin(char const*, nsIURI*, nsIPluginInstanceOwner*) 	mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp:3553
10 	nsObjectFrame::InstantiatePlugin(nsIPluginHost*, char const*, nsIURI*) 	mozilla/layout/generic/nsObjectFrame.cpp:794
11 	nsObjectFrame::Instantiate(char const*, nsIURI*) 	mozilla/layout/generic/nsObjectFrame.cpp:1505
12 	nsObjectLoadingContent::Instantiate(nsIObjectFrame*, nsACString_internal const&, nsIURI*) 	mozilla/content/base/src/nsObjectLoadingContent.cpp:1593
13 	nsAsyncInstantiateEvent::Run() 	mozilla/content/base/src/nsObjectLoadingContent.cpp:146
14 	nsThread::ProcessNextEvent(int, int*) 	mozilla/xpcom/threads/nsThread.cpp:510
15 	NS_ProcessNextEvent_P(nsIThread*, int) 	nsThreadUtils.cpp:227
16 	nsBaseAppShell::Run() 	mozilla/widget/src/xpwidgets/nsBaseAppShell.cpp:154
17 	nsAppStartup::Run() 	mozilla/toolkit/components/startup/src/nsAppStartup.cpp:181
18 	XRE_main 	mozilla/toolkit/xre/nsAppRunner.cpp:3149
19 	main 	mozilla/browser/app/nsBrowserApp.cpp:158
Severity: normal → critical
Keywords: crash, testcase
Summary: Applets crash the browser in linux with 1.6 JDK → Applets crash the browser in linux with 1.6 JDK [@ libjavaplugin_nscp.so] [@ ProxyJNIEnv::ProxyJNIEnv]
Danielle, could this be an issue of the latest Java version?

Comment 3

10 years ago
I am not able to reproduce the crash when running the 1.4 demo applets in the URL provided (http://java.sun.com/applets/jdk/1.4/index.html).
I tried 6u4 b12 and 6u10 b12 on both Solaris and Linux.

Could you please indicate which applet from that URL that causes the crash? Thanks.
(Reporter)

Comment 4

10 years ago
I can't replicate that crash now.  I have tried with both the 2008021604 build and the latest build, and can't replicate the crash now... 

Not sure what to make of it.  I remember it crashing with the fractal and the jumping box applets.
As I've seen today under OS X while trying to reproduce another crash it's sometimes bad to restart the pc. :/ I think you did that within the last days. Try to remember the open tabs, click through all visited pages that day... perhaps you can find a way to get it reproduced.

Comment 6

10 years ago
OS X is currently not under Sun Java supported configuration.
With Linux and Solaris, no crash is reproducible with the 1.4 demo applets, including Fractal and Jumping box. 
Tried opened multiple tabs, back-forth repeatedly to reload multiple applets, restart browser with previous loaded tabs, etc, still no crash.

Please let know if you find more definite way to reproduce problem.
Otherwise, I guess this bug can be closed?

Comment 7

10 years ago
is this bug 419818?

Comment 8

10 years ago
Don't think so as this bug here already occurred with the "old" Java plugin 1.6.0_04, Bug 419818 only happens with the new u10 plugin.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
(Assignee)

Updated

7 years ago
Crash Signature: [@ libjavaplugin_nscp.so] [@ ProxyJNIEnv::ProxyJNIEnv]

Comment 9

6 years ago
OJI has been discontinued and Java now runs out-of-process, so this stuff has probably changed a lot. This bug has no info about current software versions, please file a new bug for new issues or reopen this one with current info, including a crash signature if it still happens and move it to a component outside of graveyard.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.