Firefox 3.0b4pre hangs starting BBC iplayer



Plugins Graveyard
RealPlayer (Real)
10 years ago
2 years ago


(Reporter: Aaron Sloman, Unassigned)


({crash, qawanted})

crash, qawanted
Bug Flags:
blocking1.9 -




(1 attachment)



10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre

When I try to start the BBC iplayer (which works fine on firefox 2) the latest firefox 3 hangs. I can't close any firefox windows normally and have to kill firefox from the command line. This happens when I try to play audio. I have not got as far as trying to use the iplayer with video, but I expect the same thing will happen.

I am running fedora 6 with software suspend 2

I have realplayer version (gold), which is used by the
iplayer for audio. 

Reproducible: Always

Steps to Reproduce:
1.start latest firefox on my linux pc 
2.Try to start 
Actual Results:  
Firefox freezes.

Expected Results:  
iplayer should start up with options to select audio program.

Comment 1

10 years ago
Sorry, I was having problems with Minefield/3.0b4pre and forgot to complete
the steps to reproduce before sending. I am now using firefox 2 again.

Steps to reproduce:
1. start latest firefox (minefield)
2. get url:
3. Select a radio programme (e.g. one of the music programmes).

Everything then hangs. It works fine in Firefox/

NOTE: the BBC iplayer video works fine. The problem is with radio programmes only.
Flags: blocking-firefox3?
Keywords: crash
Clearing nomination until we get a confirmation.

Tony: can you get some QA testing on this? Breaking the BBC ain't kosher! ;)
Flags: blocking-firefox3?
Keywords: qawanted
i will take a look at this :-) 
Created attachment 304218 [details]
stack from windbg

(In reply to comment #2)
> Clearing nomination until we get a confirmation.
> Tony: can you get some QA testing on this? Breaking the BBC ain't kosher! ;)

I guess this is something Plugin (Real Player in this case) related, i also crash with  Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9b4pre) Gecko/2008021804 Minefield/3.0b4pre using the url from this bug. 

012f988 63b0c29b nppl3260!native_RAPlayer_ProcessIdle+0x69b
0012f9c4 608db66e nppl3260!unuse_netscape_plugin_Plugin+0x21bb
0012fa64 609d6ffa xul!nsPluginHostImpl::InstantiateEmbeddedPlugin(char * aMimeType = 0x04dd7198 "audio/x-pn-realaudio-plugin", class nsIURI * aURL = 0x04ee1530, class nsIPluginInstanceOwner * aOwner = 0x04ea5c80)+0x6e3 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\modules\plugin\base\src\nspluginhostimpl.cpp @ 3605]
0012fb1c 60957e2c xul!SearchTable(struct PLDHashTable * table = 0x02ce51fc, void * key = 0x60957e2c, unsigned int keyHash = 0x6f56c0, PLDHashOperator op = 1620409854 (No matching enumerant))+0xb6 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\obj-fx-trunk\xpcom\build\pldhash.c @ 446]
0012fb24 60957dfe xul!nsBaseAppShell::QueryInterface(struct nsID * aIID = 0x60c31f20, void ** aInstancePtr = 0x00000008)+0x17 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\widget\src\xpwidgets\nsbaseappshell.cpp @ 49]
0012fb84 609d73bf xul!nsBaseAppShell::Release(void)+0x10 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\widget\src\xpwidgets\nsbaseappshell.cpp @ 49]
0012fb90 6080ca60 xul!nsCOMPtr_base::assign_from_qi(class nsQueryInterface qi = class nsQueryInterface, struct nsID * iid = 0x00000008)+0x16 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\obj-fx-trunk\xpcom\build\nscomptr.cpp @ 96]
0012fbbc 6080d714 xul!nsObjectFrame::InstantiatePlugin(class nsIPluginHost * aPluginHost = 0x00000000, char * aMimeType = 0x04dd7198 "audio/x-pn-realaudio-plugin", class nsIURI * aURI = 0x04ee1530)+0x9a [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nsobjectframe.cpp @ 794]
0012fbf4 6082f00d xul!nsObjectFrame::Instantiate(char * aMimeType = 0x04dd7198 "audio/x-pn-realaudio-plugin", class nsIURI * aURI = 0x04ee1530)+0xa6 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nsobjectframe.cpp @ 1508]
0012fc20 6082ce5d xul!nsObjectLoadingContent::Instantiate(class nsIObjectFrame * aFrame = 0x04ef0dd8, class nsACString_internal * aMIMEType = 0x00000000, class nsIURI * aURI = 0x0012f948)+0x6b [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\content\base\src\nsobjectloadingcontent.cpp @ 1593]
0012fc3c 609df34b xul!nsAsyncInstantiateEvent::Run(void)+0x59 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\content\base\src\nsobjectloadingcontent.cpp @ 147]
0012fc5c 609bfe94 xul!nsThread::ProcessNextEvent(int mayWait = 1, int * result = 0x0012fc70)+0xc0 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\threads\nsthread.cpp @ 511]
0012fc74 60957f39 xul!NS_ProcessNextEvent_P(class nsIThread * thread = 0x00000000, int mayWait = 1244952)+0x1d [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\obj-fx-trunk\xpcom\build\nsthreadutils.cpp @ 227]
0012fc80 6089bf21 xul!nsBaseAppShell::Run(void)+0x25 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\widget\src\xpwidgets\nsbaseappshell.cpp @ 153]
0012fc8c 604a8436 xul!nsAppStartup::Run(void)+0x1e [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\components\startup\src\nsappstartup.cpp @ 182]
0012ff18 00401466 xul!XRE_main(int argc = 1, char ** argv = 0x006220a0, struct nsXREAppData * aAppData = 0x00615400)+0x182e [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\xre\nsapprunner.cpp @ 3151]
0012ff50 00401226 firefox!NS_internal_main(int argc = 1, char ** argv = 0x00000000)+0x1d5 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\browser\app\nsbrowserapp.cpp @ 159]
0012ff80 00401632 firefox!wmain(int argc = 6430880, wchar_t ** argv = 0x0061e0f0)+0xf5 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\xre\nswindowswmain.cpp @ 89]
0012ffc0 7d4e7d2a firefox!__tmainCRTStartup(void)+0x152 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\obj-fx-trunk\memory\jemalloc\src\crtexe.c @ 591]
0012fff0 00000000 kernel32!BaseProcessStart+0x28


10 years ago
Component: General → Plug-ins
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
Version: unspecified → Trunk
QA Contact: general → plugins

Comment 5

10 years ago
I was able to reproduce this crash on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031204 Minefield/3.0b5pre by navigating to that URL.   Unfortunately, Breakpad is still backlogged with all the crash reports so i only see a 404 error on the site.   I'll add my stack trace to this bug when its working again.
Flags: blocking1.9?
Not blocking on this, not sure whether this is our fault or the real player plugins fault. I do have an experimental patch that might help though, more later...
Flags: wanted1.9+
Flags: blocking1.9?
Flags: blocking1.9-
Note: this still crash when the real Player Plugin is installed and with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9pre) Gecko/2008052106 Minefield/3.0pre ID:2008052106

But might still also a real player problem.

You don't crash on when you have not the plugin installed also.
Summary: Firefox 3.0b4pre (on linux) hangs starting BBC iplayer → Firefox 3.0b4pre hangs starting BBC iplayer
Poked around a fair bit on, using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008051202 Firefox/3.  I'm on Ubuntu 8.04, using (Helix DNA Plugin: RealPlayer G2 Plug-In Compatible version built with gcc 3.4.3 on Feb 25 2008) -- just a datapoint (I did crash once, but it was in Flash, and unrelated, as it was before I had even yet installed Helix).
(Nor did I hang, since the bug seems to cover both right now.)

Comment 10

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

No crash on RC2. XP SP3 here. No hang either. Works pretty smoothly. 

Comment 11

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9) Gecko/2008052906 Firefox/3.0

I have the same problem with the Firefox 3.0 final version. On Windows XP SP3

Comment 12

10 years ago
Mozilla/5.0(Windows; U; Windows NT 5.1; de; rv:1.9)Gecko/2008052906 Firefox/3.0

1. Open the iPlayer on the BBC website
2. Select the radio station
3. Firefox freezes

js problem?

Comment 13

10 years ago
Do you have the latest flash and realplayer?

It all works for me with Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9) Gecko/2008052912 Firefox/3.0 on Linux (Fedora 6 and Fedora 8) with Flash 9 (earlier versions don't work) for some things and either realplayer (version (experimental) or mplayer for others.
Sometimes there is a significant pause while it connects.

I don't understand why the iplayer behaves differently on different radio programmes. But as long as it works, I don't mind.

I have not tried it on windows. Never use that.

Comment 14

10 years ago
Firefox 3.0.1 crashes to the Microsoft "send/don't send" box when attempting to start iplayer for Radio 3. XP SP3 Home. Scripts are allowed (with NoScript) for BBC. Repeatable:

Go to BBC iplayer web site (
Click on Radio 3.
Try to play anything.
Crashes to Send/Don't Send box. No Talkback apparently (I did "standard" install).

On upgrade from (where iPlayer worked) a "RealPlayer Browser Record Plugin 1.0" (listed in Extensions) was disabled as incompatible with FF3 - but I'm not allowed to uninstall it either. However, the regular RealPlayer plugin (listed in Plugins) seems to have come through OK.

I'll try it again and see if I can find the minidump that MS creates.

Comment 15

10 years ago
Here are the error logs from XP's event viewer, if it might help:

Faulting application firefox.exe, version, faulting module nppl3260.dll, version, fault address 0x000054bb.

Fault bucket 834240281.

Looks like it's in the RealPlayer plugin based on version numbers, so this might not be directly one of yours. However, it only broke in the transition from 2 to 3 so something happened in FF to trigger it.

Comment 16

10 years ago
I have the crash on using iplayer in Firefox but it works fine in IE. Crash report:

Problem signature
Problem Event Name:	APPCRASH
Application Name:	firefox.exe
Application Version:
Application Timestamp:	486bac70
Fault Module Name:	nppl3260.dll
Fault Module Version:
Fault Module Timestamp:	4775bfe1
Exception Code:	c0000005
Exception Offset:	000054bb
OS Version:	6.0.6001.
Locale ID:	2057
Additional Information 1:	c028
Additional Information 2:	4243315ca10891403afd18c53338927f
Additional Information 3:	758b
Additional Information 4:	98726f8245e1415c110dbfad24ec0c8a

Comment 17

10 years ago
people (comment, comment 15:mike b) who want to give us useful stack information should read

(this doesn't apply to people like tomcat who are already doing that).

note that bugs should really be limited to a single cause, in this case the first found cause is real player.

Comment 18

10 years ago
kev: please find us a real networks contact.
Assignee: nobody → kev

Comment 19

10 years ago
Just to confirm: I have the BBC iplayer working fine on Linux (Fedora 8 and 9) with Firefox: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/2008070206 Firefox/3.0.1.

I had to install the latest Flash (version and the latest realplayer (RealPlayer for Linux March 2008).

My guess is that the first thing to try if anyone has trouble with iplayer is installing the latest version of flash and the latest realplayer.

Could FF 3 be made to check and give a recommendation?


10 years ago
Blocks: 452045

Comment 20

10 years ago
Problem resolved. In Windows, fully uninstalled Realplayer, then upgraded Firefox to 3.0.4, then reinstalled Realplayer 11 (current). iPlayer now works. The eye candy on the Radio 3 page is gone - might have to reinstall Flash etc too - but the player works which was the original bug. 

Suggest the FF3 installer check for presence of Realplayer plugin and warn about possible incompatibility if FF2 plugin is carried forward. Also, the Realplayer Record plugin from FF2 is disabled when FF3 is installed, but then cannot be removed from within FF3. But it works if Realplayer is uninstalled first then added back once FF3 is done.

Comment 21

8 years ago


8 years ago
Assignee: kev → nobody
Component: Plug-ins → RealPlayer (Real)
Flags: wanted1.9+
Product: Core → Plugins
QA Contact: plugins → real-player
Version: Trunk → 6.x

Comment 22

2 years ago
Closing old bugs in the Plugins component. We aren't going to track issues in 3rd-party plugins in the Mozilla bug tracker. In addition, support for NPAPI plugins will be removed at the end of this year; for more details see the post at

If there is a serious bug in Firefox, it needs to be filed in the "Core" product, "Plug-Ins" component.
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE


2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.