Usability: Back button is not clickable at the edge of the screen

VERIFIED DUPLICATE of bug 414842

Status

()

VERIFIED DUPLICATE of bug 414842
11 years ago
11 years ago

People

(Reporter: mikko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

In full screen mode, back button is clickable 1-2 pixels from the screen edge, but not at the screen edge. This violates the usability principle that things that are near the edges of the screen should be also clickable at the edges of the screen. The screen edge is the easiest place to move your mouse cursor. Now you need to come few pixels back.




Reproducible: Always

Steps to Reproduce:
1. Enter full screen mode 
2. Move mouse to the left edge of the screen near back button
3. Click
Actual Results:  
Nothing happens

Expected Results:  
Back button is highlighted and responds to the click

http://www.osnews.com/story/18893/Common_Usability_Terms_pt._IV:_Fitts_Law

"The most debated consequence of Fitts' law is the importance of edges and corners. Because the mouse cursor cannot travel beyond screen edges and corners, they are seen as infinitely large targets - which Fitts' law really likes. The two prime examples of this are the global menubar in the Mac OS, and the start button in Windows; you can blindly move the mouse to the lower-left corner of a Windows desktop, and it will always hit the clickable area of the start button (since my Vista laptop died due to hardware failure, I cannot confirm this behaviour for the new start 'orb' in Windows Vista). Windows also uses Fitts' law in the taskbar, allowing you to hit entries in the taskbar despite the fact that the buttons do not cover the bottom two pixels of the taskbar."
Dupe of bug 415497 or bug 414842?

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414842
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.