Closed Bug 418122 Opened 12 years ago Closed 11 years ago

Documented -moz-outline keywords failing (dotted)

Categories

(Core :: CSS Parsing and Computation, defect, minor)

x86
Windows 2000
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 359497

People

(Reporter: mcow, Unassigned)

Details

Gecko/2008021704 Minefield/3.0b4pre

I'm unsure whether this is valid.  I can't find a reference to 'outline' in CSS3, maybe the attribute has been dropped or maybe CSS3 is just too complex to navigate.  But anyway, I have in a custom stylesheet (for Thunderbird chrome) a rule that uses -moz-outline:
 { -moz-outline: 1px dotted invert !important; }

This was parsed fine with Tb 2.0, but now I'm getting an error in the console:
  Warning: Expected color but found 'dotted'.  Expected color but found
  'invert'.  Expected end of value for property but found 'invert'.
  Error in parsing value for property '-moz-outline'.  Declaration dropped.

I did find bug 335394, which seems to have dropped 'invert'.  Both keywords are legal per:
  http://developer.mozilla.org/en/docs/CSS:-moz-outline
So, if the bug is totally invalid from a code point of view -- that is, if 'dotted' has also been dropped -- the bug is valid from a documentation standpoint; please reassign if that's the case.
outline is part of CSS 2.1 (http://www.w3.org/TR/CSS21/ui.html#propdef-outline-color) and CSS 3 Basic User Interface (http://www.w3.org/TR/css3-ui/#outline-color0).

You should use the property without -moz-prefix, as these will eventually be removed. 'outline' is fine.

Ok, about 'invert': According to CSS it's legal not to support it, which currently is the case due to architectural changes. However, this is seen as a regression, and Bug 359497 may eventuelly implement 'invert' again.

'dotted' is still valid, the parser simply got confused.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359497
Filed bug 469580 on the incorrect and misleading error message.
You need to log in before you can comment on or make changes to this bug.