Fixed size of PATH_MAX variable cashes browser compiled with new gcc and static string size check.

RESOLVED DUPLICATE of bug 412610

Status

()

--
critical
RESOLVED DUPLICATE of bug 412610
11 years ago
10 years ago

People

(Reporter: stransky, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 304033 [details] [diff] [review]
proposed patch - replaces the hardcoded values on linux.

Default PATH_MAX is somewhere hardcoded to 1024. But the system size of PATH_MAX is usually bigger (4096).

For instance, when realpath is called with 1024 byte buffer (and expects 4096 bytes here), browser crashes.

from stdlib.h:

extern char *realpath (__const char *__restrict __name,
                       char *__restrict __resolved) __THROW __wur;
Can any Linux user confirm?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 412610
You need to log in before you can comment on or make changes to this bug.