Firefox should respect "Hide underlined letters for keyboard navigation..." Windows setting

VERIFIED DUPLICATE of bug 170029

Status

()

Firefox
Shell Integration
VERIFIED DUPLICATE of bug 170029
10 years ago
10 years ago

People

(Reporter: Dan Tilden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

In Windows 2000, XP, and Vista, there is a setting in the control panel to "Hide underlined letters for keyboard navigation until I press the Alt key."  When this is enabled (which it is by default), two things occur:

1. Alt-key hotkeys are not shown as underlined in a window until the alt key is pressed down.
and 
2. A dotted black border is shown around focused controls only if the TAB key is used for keyboard navigation.

Firefox, however, regardless of the setting, always acts as if it is disabled, and displays both the underlined letters for keyboard navigation and the dotted black border around focused controls.

Reproducible: Always

Steps to Reproduce:
1. Enable the "Hide underlined letters for keyboard navigation until I press the Alt key" checkbox from the "Effects..." window in the "Appearance" tab of "Display Properties".
2. Start Firefox.

Actual Results:  
Controls still retain dotted black focus rings and underlined keyboard navigation shortcuts.

Expected Results:  
Firefox should not show alt-key navigation shortcuts as underlined in a window until the alt key is pressed down, and the dotted black focus ring should only be shown around focused controls if the TAB key is used for keyboard navigation.
(Reporter)

Comment 1

10 years ago
Created attachment 304139 [details]
Demonstration of the problem, comparing some native checkboxes to Firefox ones
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 170029

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.