Status

P3
normal
VERIFIED INVALID
20 years ago
10 years ago

People

(Reporter: jt, Assigned: mcafee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
The actual error is :
-------------------------------
<jean@tourrilhes>../package/apprunner
nsComponentManager: Using components dir: /home/jean/mozilla/package/components
Argument: -progname, ****** Value: ../package/apprunner
iconic  state not set
width was not set
height was not set
Got thew event queue from the service
Calling gdk_input with event queue
Reading file...
Reading file...Done

Gdk-ERROR **: BadAccess (attempt to access private resource denied)
  serial 2014 error_code 10 request_code 132 minor_code 3

aborting...
Abort
---------------------------------
	System :
		PPro 200, 128 MB, Debian 2.1, Linux 2.0.36, tcsh.
	Mozilla :
		mozilla-i686-pc-linux-gnu-SeaMonkey_M3_BRANCH.tar.gz
	Setup :
		As advertised on web page.
		MOZILLA_FIVE_HOME=/home/jean/mozilla/package
		LD_LIBRARY_PATH=/home/jean/mozilla/package:/lib:/usr/lib
	Notes :
		I don't have GTK or Gnome installed.
		Netscape 4.07 installed and working.
		Proxy access through firewall.

	Good luck !

	Jean

Updated

20 years ago
Assignee: don → michaelp
Component: Apprunner → Compositor

Comment 1

20 years ago
Re-assinged to michaelp@netscape.com and changed component to Compositor.

Updated

20 years ago
Assignee: michaelp → ramiro

Updated

20 years ago
Target Milestone: M7

Comment 2

20 years ago
It worked for me as late as apr 5.

if you provide a stack trace, i might be able to get more clues.

marking m7.

Comment 3

20 years ago
Additional comment from Jean via mail:
"I did a bit more searching. The problem is consistent : it is still there. I've
upgraded to kernet 2.2.4 no go. But, if I run netscape 4 before starting
mozilla, the problem goes away. I suspect that netscape 4 set something in my
user environment that mozilla needs."

Updated

20 years ago
Assignee: ramiro → mcafee

Comment 4

20 years ago
reassign what appears to be an apprunner specific thing to mcafee.

works fine in viewer for me.
(Assignee)

Comment 5

20 years ago
I do not understand how to reproduce this bug, or what
the problem is.  Apprunner is running fine for me
on Solaris and Linux.
(Reporter)

Comment 6

20 years ago
I'm sorry if things are a bit confuse, but it's quite difficult for me to know
what are the exact conditions triggering the bug.

	This is how I can reproduce the bug :
	1) Reboot the machine
	2) rlogin to it
	3) setenv DISPLAY ...
	4) setenv MOZILLA_FIVE_HOME & LD_LIBRARY_PATH
	5) start apprunner
	Subsequent invocation of apprunner, however, will succed and start up Mozilla
correctly (so, it is only the first time after reboot).

	If I remember correctly, at the very beggining apprunner was always failing
(first and subsequent invocations), but this has gone since I've ran Netscape as
this user. As I can't reproduce any more this failure, caution...

	In summary :
	o Running Netcsape for the user did help
	o First invocation after reboot always fail (through rlogin)

	That's it...

	Jean
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID
(Assignee)

Comment 7

20 years ago
This bug is too vague for me to look at this.
Jean, try removing your ~/.mozilla/registry file
before starting, sometimes this helps.

Marking invalid; Jean please file a more-specific bug
if you continue to see problems.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 8

20 years ago
Jean....check out http://www.mozilla.org/quality/bug-writing-guidelines.html

This should help you help us!  -Jan
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.