Sisyphus/JavaScript Tests - handle malformed log files

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: bc, Assigned: bc)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

11 years ago
Created attachment 304481 [details] [diff] [review]
post-process-logs.pl patch

When originally developed, post-process-logs.pl was designed to handle the restart mode of browser testing where the browser was started, the test run, then the browser shut down for each test. When adding the ability for the framework to run in non-restart mode, it became important to become much more strict in dealing with the processing of the test beginning, test running, test reporting, and test conclusion since there was no longer a clear boundary formed by the program execution. This has worked fairly well for linux and mac, however the log files on windows have been problematic due to ordering issues and buffering issues in the logs.

This patch relaxes several constraints in post-process-logs.pl to handle the "malformed" logs produced on windows machines.
Flags: in-testsuite-
Flags: in-litmus-
(Assignee)

Comment 1

11 years ago
Created attachment 304482 [details] [diff] [review]
public-failures.txt patch

piggy back related and other changes to public failures.
(Assignee)

Comment 2

11 years ago
Created attachment 304483 [details] [diff] [review]
spidermonkey-extensions-n.tests patch

piggy back update to the list of tests in /extensions/
(Assignee)

Comment 3

11 years ago
/cvsroot/mozilla/js/tests/post-process-logs.pl,v  <--  post-process-logs.pl
new revision: 1.7; previous revision: 1.6

/cvsroot/mozilla/js/tests/public-failures.txt,v  <--  public-failures.txt
new revision: 1.41; previous revision: 1.40

/cvsroot/mozilla/js/tests/spidermonkey-extensions-n.tests,v  <--  spidermonkey-extensions-n.tests
new revision: 1.11; previous revision: 1.10
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Mass move of Sisyphus bugs to Testing : Sisyphus. Filter on SisyphusMassMove to ignore.
Component: Testing → Sisyphus
Flags: in-litmus-
Product: Core → Testing
QA Contact: testing → sisyphus
You need to log in before you can comment on or make changes to this bug.