Closed Bug 418630 Opened 14 years ago Closed 14 years ago

when inserting into a toolbar folder or chevron we get a selectItems error in the console

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta4

People

(Reporter: mak, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(1 file)

probably a regression from the selection bug, if you right click on a folder in the toolbar and choose insert new separator (or another item) you get an error  on selectItems. we should not select in the menupopups.

asking blocking since it's a quite common task for a user and it should not fire an error in the console.
Flags: blocking-firefox3?
Attached patch patchSplinter Review
adding selectItems to toolbar and menu views
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #304721 - Flags: review?(mano)
Blocks: 332047
Keywords: regression
Comment on attachment 304721 [details] [diff] [review]
patch

I would make that "Be Gentle, Do Nothing."

r=mano either way.
Attachment #304721 - Flags: review?(mano) → review+
Priority: -- → P1
Target Milestone: --- → Firefox 3 beta4
or "Be honest, select something". thx for quick review
Keywords: checkin-needed
Keywords: checkin-needed
Attachment #304721 - Flags: approval1.9?
drivers, real low impact fix for a regression due to another fix
Flags: blocking-firefox3? → blocking-firefox3+
Priority: P1 → P2
Comment on attachment 304721 [details] [diff] [review]
patch

a=beltzner for 1.9
Attachment #304721 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
mozilla/browser/components/places/content/menu.xm 1.102
mozilla/browser/components/places/content/toolbar.xml 1.124
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre)
Gecko/2008022704 Minefield/3.0b4pre and Mozilla/5.0 (Macintosh; U; Intel Mac OS
X 10.4; en-US; rv:1.9b4pre) Gecko/2008022704 Minefield/3.0b4pre
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.