Closed Bug 418657 Opened 12 years ago Closed 12 years ago

[Task List] Hide Completed Task feature is broken

Categories

(Calendar :: Provider: Local Storage, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: Fallen)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre) Gecko/2008022007 Calendar/0.8pre
 and
Thunderbird 2.0.0.13pre (2008021903) + Lightning 0.8pre (2008022009)

1. Start Sunbird with clean profile
2. Create some new tasks and mark some as Completed
3. Mark the checkbox Hide Completed Task

Actual results:
There is still all entries in task list but the displayed text is "false" in all columns. Error Console shows:

Error: item has no properties
Source file: chrome://calendar/content/calendar-task-tree.xml
Line: 1079

Error: Assert failed: [Exception... "'[JavaScript Error: "item has no properties" {file: "chrome://calendar/content/calendar-task-tree.xml" line: 1079}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///E:/sunbird/components/calCompositeCalendar.js :: anonymous :: line 515"  data: yes]
1: [file:///E:/sunbird/js/calUtils.js:1369] ASSERT
2: [file:///E:/sunbird/components/calCompositeCalendar.js:426] anonymous
3: [null:0] null
4: [chrome://calendar/content/calendar-task-tree.xml:872] anonymous
5: [chrome://calendar/content/calendar-task-tree.xml:957] popRefreshQueue

Source file: file:///E:/sunbird/js/calUtils.js
Line: 1373

followed by many of:

Error: task has no properties
Source file: chrome://calendar/content/calendar-task-tree.xml
Line: 344

Error: aTask has no properties
Source file: chrome://calendar/content/calendar-task-tree.xml
Line: 601
Flags: blocking-calendar0.8?
Regression range: Works in Sunbird 0.8pre (2008-02-19-03)
                  Fails in Sunbird 0.8pre (2008-02-19-20)

Checkins during regression range: http://tinyurl.com/yob92c
Seen to be a storage provider only issue because it works when using an ics calendar instead. 
Looking at the regreesion range I think Bug 366177 might be the causer.
Component: Tasks → Provider: Local Storage
QA Contact: tasks → storage-provider
Version: Mozilla 1.8 Branch → unspecified
Attached patch Fix v1 β€” β€” Splinter Review
Good catch! I admire all the QA work you guys do, it would have taken much longer to find such bugs without you :)
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #304569 - Flags: review?(ssitter)
Flags: blocking-calendar0.8? → blocking-calendar0.8+
Comment on attachment 304569 [details] [diff] [review]
Fix v1

r=ssitter
Attachment #304569 - Flags: review?(ssitter) → review+
Attached patch fix v2 (obsolete) β€” β€” Splinter Review
Unfortunately, the first version didn't correctly address the problem.
Attachment #304569 - Attachment is obsolete: true
Attachment #304585 - Flags: review?(ssitter)
Attachment #304585 - Flags: review?(ssitter) → review?(sebo.moz)
Duplicate of this bug: 418836
Blocks: 366177
Philipp, what is not working with fix v1? I tried it and it seems to work for me.
It seems I was wrong, the first version works fine for me.

We should have a unit test that checks the completed/not completed scenarios.

Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Flags: in-litmus?
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → 0.8
Flags: in-litmus? → in-testsuite?
Attachment #304585 - Attachment is obsolete: true
Attachment #304585 - Flags: review?(sebo.moz)
Attachment #304569 - Attachment is obsolete: false
Checked in nightly build 2008022418 -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.