Closed Bug 418725 Opened 12 years ago Closed 9 years ago

Unable to search all addons after initial search is cleared

Categories

(Toolkit :: Add-ons Manager, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: marcia, Unassigned)

References

Details

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008022004 Minefield/3.0b4pre.

STR:
1. Go to Addons from the Tool menu.
2. Focus the search box and type some text in the box. Hit Enter.
3. Click on Show All results to open the search in a new tab.
4. Click back to the search box and clear it using the "X' in preparation for another search. Try to type a new search term in the box.

Expected: More than 80% of the time I cannot type something new in the search box until I change focus to one of the other tabs in the Addons manager. In some cases I also cleared the text by erasing it with backspace and got the same result.

I tested this on Win XP and I don't see the same issue there.
Duplicate of this bug: 418720
Sorry about the dupe bugs - this happened when i launched a show results page and it seems that it submitted what i had written to date in the bug.
Product: Firefox → Toolkit
Old UI which has been removed with the rewrite of the EM in Firefox 4.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.