Backgrounds are extremely corrupted on some sites.

RESOLVED DUPLICATE of bug 411831

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 411831
11 years ago
8 years ago

People

(Reporter: Brent Newland, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008021416 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3) Gecko/2008021416 Firefox/3.0b3

When I visit a few sites like geeks.com and elivecd.com, the background - instead of being the website's normal background - is a tile of a portion of the screen.

Reproducible: Always

Steps to Reproduce:
1. Visit site in question (possibly just on Ubuntu)
2. Finish page load
Actual Results:  
Corrupted background

Expected Results:  
Normal background

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc-4.2 	gcc version 4.2.3 (Ubuntu 4.2.3-1ubuntu2) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -pedantic -g -fno-strict-aliasing -pthread -pipe
g++-4.2 	gcc version 4.2.3 (Ubuntu 4.2.3-1ubuntu2) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -pedantic -g -fno-strict-aliasing -fshort-wchar -pthread -pipe

Configure arguments
--build=i486-linux-gnu --prefix=/usr '--includedir=${prefix}/include' '--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' --sysconfdir=/etc --localstatedir=/var '--libexecdir=${prefix}/lib/xulrunner-1.9' --disable-maintainer-mode --disable-dependency-tracking --srcdir=. --enable-system-cairo --with-system-nspr --with-system-nss --enable-application=xulrunner --enable-extensions=xml-rpc,venkman,inspector,irc,gnomevfs,cview,tasks,reporter,python/xpcom --enable-webservices --enable-safe-browsing --with-default-mozilla-five-home=/usr/lib/xulrunner-1.9b3 --enable-startup-notification --with-user-appdir=.mozilla --with-system-jpeg=/usr --with-system-zlib=/usr --disable-javaxpcom --disable-crashreporter --disable-elf-dynstr-gc --disable-installer --disable-strip --disable-strip-libs --disable-install-strip --disable-tests --disable-mochitest --disable-updater --enable-optimize --with-distribution-id=com.ubuntu

Using Ubuntu Hardy Heron (with latest updates)
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Comment 2

10 years ago
Same problem on a dual-head amd64 gentoo box with firefox 3.0-rc1. I have current contents of the second screen rendered in the firefox window in place of the background image. 

The bug is reproducible using the following html code:

<html>
<head>
<body background="http://geeks.com/images/bg_body.gif">
</body>
</html>

Comment 3

10 years ago
I suspect this is related to bug #441369; please see my comment there for more detail (and more some testcases and outright speculation).

Comment 4

10 years ago
After some suggestions in #441369, this turns out to actually be a dupe of bug #411831, and the root cause is an X server bug; turning on XAANoOffscreenPixmaps in xorg.conf (or upgrading to a newer X server where it's off by default) fixes the problem.

Comment 5

10 years ago
Yes, indeed. Those instructions were helpful. Thank you.
Duping this to Bug #411831 as per comment #4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411831
You need to log in before you can comment on or make changes to this bug.