no support for XSLT <namespace-alias> element

RESOLVED DUPLICATE of bug 213996

Status

()

Core
XSLT
--
major
RESOLVED DUPLICATE of bug 213996
11 years ago
11 years ago

People

(Reporter: Pierrick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

when parsing a xml file using transformiix, the high level <namespace-alias> element is not recognize, therefor there is no possibility to generate a XSL file from a transformation process.

Reproducible: Always

Steps to Reproduce:
var processor = new XSLTProcessor();
processor.importStylesheet(xslName);
return processor.transformToFragment(xmlName, document);
Actual Results:  
Do not replace alias prefixes and remove them (we can't even post process it ourselves) form the tag element. No matter the xmlns specifies

Expected Results:  
Should replace an alias prefixes with the one specify :
<xsl:namespace-alias stylesheet-prefix="xslout" result-prefix="xsl"/>

<xslout:stylesheet version="1.0">
should return
<xsl:stylesheet version="1.0">

As a top level element of the xsl transformation version 1.0 recommendation, it should be handle to allow client side transformation using XSL format output.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Component: General → XSLT
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 213996
You need to log in before you can comment on or make changes to this bug.