Enable support for window.event

RESOLVED DUPLICATE of bug 218415

Status

()

--
minor
RESOLVED DUPLICATE of bug 218415
11 years ago
9 years ago

People

(Reporter: henry.fai.hang.chan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.04506.648)
Build Identifier: 

What about redirecting attached events options back to the function?

Also automatically bind event.srcElement and event.target together.

(for example)
function a(){
var k;
k = window.event.srcElement;
}

works as if it was coded

function a(event);
var k;
k = event.target;

Reproducible: Always

Steps to Reproduce:
go to a site that uses window.event
Actual Results:  
there is an error.

Expected Results:  
The browser acts as if it was an event variable called by function.

This actually just a suggestion, although many sites do NOT provide workaround, so I file as MINOR.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218415
You need to log in before you can comment on or make changes to this bug.